Task Scheduler Not Working (Stuck on "Running")

Tiago Dumont 0 Reputation points
2023-05-14T19:12:10.9766667+00:00

Hello,

I'm having trouble with tasks on a Windows Server 2012 R2 machine.

Whatever I schedule to run, gets stuck on "Running" even though nothing happens. In this specific case, I'm trying to use wbadmin to schedule weekly Windows Server Backups but I've tried running the calculator instead and it won't work either.

I have the exact same task - I copied it multiple times already to make sure I wasn't goofing something basic - on another machine running Windows Server 2022 and it runs with no problem.

I've also tried running wbadmin through CMD with the arguments in the task and it runs with no problem.

One thing to note is that the Google Tasks that were created by Chrome in order to autoupdate work when I right click them and hit "Run". Mine just hang on "Running" until I manually end them.

I'm completely lost here.

Windows Server 2012
Windows Server 2012
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
1,545 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 44,021 Reputation points
    2023-05-18T16:05:31.1866667+00:00

    Hello

    Thank you for your question and reaching out.

    1. Please Try to set it to run whether a user is logged on or not and run it with high privileges by specifying an Admin user.
    2. Please try to run completely blank or without cmd commands to check if its status changed or not.
    3. Check the job start date/time and update them.
    4. Please make sure both the task and the trigger are enabled.

    --If the reply is helpful, please Upvote and Accept as answer--

    0 comments No comments