I'm unable to connect to any NAS from ONLY my desktop on my network

Terry F 0 Reputation points
2023-05-15T11:35:41.16+00:00

Hi,

 

I have spent over a year with this problem that has persisted through upgrading to Windows 11.

I have a NAS (My Cloud Home) that I have been using to back up files which 'requires' a desktop app that is now being discontinued to use but I can enable local access and have done but am unable to access it from my desktop.

I started building my own NAS with TrueNas in hopes of solving my problem by moving to a more custom system. The problem persists.

 

It is not SMB 1.0 enabled or not. It is not an Update. It is not a PC reset nor a network reset. Its not some registry edit. I have been having so many problems and have tried so much. I have given up.

 

ALL OF THESE PROBLEMS ARE FOR MY DESKTOP. I can connect to both the NAS's from my Laptop without a problem. Without editing any settings.

 

The specific errors for my Cloud Home NAS is that I am unable to connect with a 'undiagnosed error' or when logging in with my credentials it tells me either my password or username is wrong EVERY TIME.

 

My TrueNas just won’t let me log in no matter the password or username. I entered it correctly typing it in on my laptop giving me access. Also typing it in Word and copying it over guaranteeing I typed it correctly. Yet it still says I have incorrectly typed it. EVERY TIME ONLY ON MY DESKTOP.

 

I tried Wifi vs Ethernet. Same thing. I tried different internet. Same thing.

This is not a NAS problem as I'm able to connect to them from iPhone and laptops HOWEVER the only difference being the Laptops are runnning Windows 11 & 10 Home edition while my Desktop is running 11 Pro.

 

I'm at a loss and broken. What the hell could be causing this?

Windows Network
Windows Network
Windows: A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.Network: A group of devices that communicate either wirelessly or via a physical connection.
687 questions
Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,669 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Anonymous
    2023-12-25T06:50:13.8266667+00:00

    Hello,

    Thank you for posting in Q&A forum.

    According to your statement, I would believe it's a configuration or authentication issue instead of accountname/password mismatch.

    I would suggest you checking the issue from SMB side:

    1. Check the SMB related setting between your desktop and laptop..

    a. Open PowerShell and run

    Get-smbclientconfiguration

    on both sides.

    b. Open registry editor and navigate to HKEY_LOCAL_MACHINE\CurrentControlSet\Services\LanmanWorkstation\Parameters

    on both sides.

    Somes times the configuration difference would lead to SMB connection failure.

    1. Capture network trace

    It's also recommended to capture network trace by wireshark or network monitor to capture the network traffic when reproducing the issue (fail to connect to your NAS), and you will get some insights from the trace.

    Hope this answer can you help you well.

    0 comments No comments