nslookup: "Server: Unknown"

Soar 106 Reputation points
2023-05-15T20:47:32.8833333+00:00

I've noticed that all over my network, when I nslookup any PC or server, I get "Server: Unknown" even though the DNS looks like working fine and there hasn't been any problem with name resolution in my wide multi-subnet and multi-server environment.

But recently one of our weird server applications couldn't locate some hosts, and the vendor claims that it's because of this issue.

I can ping those hosts from the respective server with no issue. And I even changed the DNS on this server to match the DNS on those hosts to no avail.

I read in more than a place that the reverse zone or pointer records can be responsible for that. But I tried nslookup on a PC that has correct A & pointer records. No difference.

How can I rectify this nslookup issue?

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,416 questions
Windows Network
Windows Network
Windows: A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.Network: A group of devices that communicate either wirelessly or via a physical connection.
681 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Karlie Weng 15,676 Reputation points Microsoft Vendor
    2023-05-16T02:46:13.58+00:00

    Hello @ Soar 

    Have you tried to specify a DNS server nslookup -IP 8.8.8.8, can it resolve the address ?

    Also flush DNS cache: ipconfig /flushdn

    Next try temporarily disabling any firewall or antivirus software and see if the issue is resolved.