Can't connect to Integration Service File System Access Denied

Anonymous
2023-05-17T01:53:46.6966667+00:00

User's image

Access to laptop- is denied, resolved IP address is ::1, network type is OnPremise'.\r\nAccess to laptop is denied, resolved IP address is ::1, network type is OnPremise\r\n"

User's image

  • My regedit RestrictAnonymous value is 0
  • The rest of my pipeline is working fine
  • I can't connect to my integrated service, even though it is running fine
  • Folder is shared

Can someone assist me? Are there any other permissions I can try to change?

Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
9,941 questions
{count} votes

1 answer

Sort by: Most helpful
  1. PRADEEPCHEEKATLA-MSFT 83,306 Reputation points Microsoft Employee
    2023-05-17T09:52:21.3766667+00:00

    @Anonymous - Thanks for the question and using MS Q&A platform.

    According to the offical documentation, the latest SHIR has a security fix that has been changed and does not allow access to local files by default.

    User's image

    You must run .\dmgcmd.exe -DisableLocalFolderPathValidation to disable the setting for more details, refer to Set up an existing self-hosted IR via local PowerShell

    User's image

    User's image

    Default: Enable security validation to disable access to file system of the local machine.

    Errorcode22853

    After Disabling access to file system of the local machine using: .\dmgcmd.exe -DisableLocalFolderPathValidation able to access the data from linked service.

    Resolve

    Hope this helps. Do let us know if you any further queries.


    If this answers your query, do click Accept Answer and Yes for was this answer helpful. And, if you have any further query do let us know.