The "Project System Components" package did not correct Visual Studio 2022 17.6

Dody Gunawinata 30 Reputation points
2023-05-17T13:07:59.4966667+00:00

ActivityLog.xmlcomponent

  • I upgraded from Visual Studio 2022 17.5. It broke after 17.6
  • I removed the installation and reboot my Windows 11.
  • I installed V2022 17.6 again fresh.
  • The workload is ASP.NET Core/Web Development workload.

I had no problem in the previous version 17.5.

I attached my ActivityLog.xml as well.

I tried all the techniques here as well https://stackoverflow.com/questions/17574089/how-can-i-fix-the-microsoft-visual-studio-error-package-did-not-load-correctly.

But again, this is a brand new installation.

Microsoft Visual Studio Community 2022 Version 17.6.0 VisualStudio.17.Release/17.6.0+33712.159 Microsoft .NET Framework Version 4.8.09032 Installed Version: Community ASP.NET and Web Tools 17.6.326.62524 ASP.NET and Web Tools Azure App Service Tools v3.0.0 17.6.326.62524 Azure App Service Tools v3.0.0 Azure Functions and Web Jobs Tools 17.6.326.62524 Azure Functions and Web Jobs Tools C# Tools 4.6.0-3.23259.8+c3cc1d0ceeab1a65da0217e403851a1e8a30086a C# components used in the IDE. Depending on your project type and settings, a different version of the compiler may be used. Common Azure Tools 1.10 Provides common services for use by Azure Mobile Services and Microsoft Azure Tools. Microsoft JVM Debugger 1.0 Provides support for connecting the Visual Studio debugger to JDWP compatible Java Virtual Machines NuGet Package Manager 6.6.0 NuGet Package Manager in Visual Studio. For more information about NuGet, visit https://docs.nuget.org/ Razor (ASP.NET Core) 17.6.0.2326105+37f2727000f6a964584cafb86e69cf0b39baecb7 Provides languages services for ASP.NET Core Razor. SQL Server Data Tools 17.6.13.0 Microsoft SQL Server Data Tools TypeScript Tools 17.0.20329.2001 TypeScript Tools for Microsoft Visual Studio Visual Basic Tools 4.6.0-3.23259.8+c3cc1d0ceeab1a65da0217e403851a1e8a30086a Visual Basic components used in the IDE. Depending on your project type and settings, a different version of the compiler may be used. Visual F# Tools 17.6.0-beta.23174.5+0207bea1afae48d9351ac26fb51afc8260de0a97 Microsoft Visual F# Tools Visual Studio IntelliCode 2.2 AI-assisted development for Visual Studio.

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
4,851 questions
{count} votes

8 answers

Sort by: Most helpful
  1. Richard Adams 15 Reputation points
    2023-05-22T08:08:05.84+00:00

    I have the same issue too following the last update (VS 2022 Professional 17.6.0)

    • Cleared cache
    • Deleted User folders
    • Repaired installation
    • Removed and did a clean install
    • All extensions disabled and still not working

    Concerned I'm going to have to reinstall my machine just to get VS working again

    1 person found this answer helpful.

  2. Rick Wheeler 5 Reputation points
    2023-05-22T11:36:49.55+00:00

    Same here. I've tried rolling back to 17.5.5, now I've uninstalled & reinstalled VS altogether. Same issue.

    1 person found this answer helpful.

  3. serikT 5 Reputation points
    2023-05-22T23:46:00.23+00:00

    I had to uninstall the dysfunctional VS17.6 and install back the working VS17.5.5.
    Microsoft has "fixed version bootstrappers" available for installation: https://learn.microsoft.com/en-us/visualstudio/releases/2022/release-history#updating-your-installation-to-a-specific-release

    Worked for me. Will stay at 17.5.5 for now.

    Happy coding!

    1 person found this answer helpful.

  4. Anna Xiu-MSFT 27,726 Reputation points Microsoft Vendor
    2023-05-18T03:26:24.64+00:00

    Hi @Dody Gunawinata

    Welcome to Microsoft Q&A! 

    Could you successfully launch your Visual Studio 2022 in Safe Mode (run devenv /SafeMode in Developer Command Prompt for VS 2022)? 

    If your VS2022 works fine in safe mode, it may be caused by the installed extensions.

    You can disable or uninstall the installed extensions under Extensions > Manage Extensions > Installed

    Sincerely,

    Anna


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment". 
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  5. Mohammad Mehrnia 0 Reputation points
    2023-05-19T06:46:31.3366667+00:00

    I have a same problem and can not open . Net framework app in safe mod