Opening excel from teams with macro that are blocked

Guy Henckaerts 0 Reputation points


I'm opening an Excel file from a teams location. The excel contains macro's that are disabled when opening the excel. How to enable them? in the Trust center the macro's are enabled. But they are not...

Microsoft Teams
Microsoft Teams
A Microsoft customizable chat-based workspace.
9,587 questions
A family of Microsoft spreadsheet software with tools for analyzing, charting, and communicating data.
1,681 questions
Excel Management
Excel Management
Excel: A family of Microsoft spreadsheet software with tools for analyzing, charting, and communicating data.Management: The act or process of organizing, handling, directing or controlling something.
1,689 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Emily Hua-MSFT 27,601 Reputation points

    Hi @Guy Henckaerts

    Are these macros disabled if you open Excel files via Excel desktop app?

    If so, I would suggest you try following steps to have a check.

    • For files stored Files stored on SharePoint, including a site used by a Teams channel, please designate the location, such as https://{your-domain-name} , as a Trusted site.
    • If conditions permit, it is recommended to download the Excel file to Trusted Locations that set in Office apps, and open it via Excel desktop app to check this issue.

    If the issue still occurs, I suggest you check whether the file is removed Mark of the Web.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.

  2. Tanay Prasad 2,115 Reputation points


    If the macros in your Excel file are disabled even though you have enabled macros in the Trust Center, it's possible that your file has been opened in a "Protected View."

    So if that is the case, you'll have to disable the protected view.

    Is there any specific error message you are facing?

    Try referring to this link if that is the case and you may just find the fix.

    Best Regards.

    0 comments No comments