(SOLVED) App Fails with "Could not load file or assembly" Error on Windows 10 PC: How to Fix It?

Lamont 0 Reputation points
2023-05-18T09:49:32.6533333+00:00

I'm a user and trying to run Duplicate Cleaner Pro 5 on my Windows 10 computer, but I'm getting this error message:

Error starting up Duplicate Cleaner: Could not load file or assembly ‘System.Data, Version =4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089’ or one of its dependencies. The system cannot find the file specified. DataPath=C:\Users\geotalk\AppData\Roaming\DigitalVolcano\DuplicateCleaner

I have browsed through many search results, but none of those were for users, and the issue remains unresolved. I believe the problem is caused by missing or corrupted files on my computer or a pointer pointing in the wrong direction. I have tried many things, such as running DISM (failed), turning .NET Framework feature off and on, going back to the last restore point (failed), resetting the system (failed), running DISM again using the Windows folder on another computer (succeeded), running sfc (it found and repaired some corrupted files), and running the .NET Framework repair tool (it didn't find any problems it could fix).

What else can I do to fix this issue?

.NET
.NET
Microsoft Technologies based on the .NET software framework.
3,613 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Lamont 0 Reputation points
    2023-05-18T23:42:16.9866667+00:00

    I copied System.Data.dll in the GAC folders from the computer where DC was working to the one where it wasn't, and now it's working.

    I'm still concerned about other files possibly missing from my .NET Framework, and why the System.Data files were not restored by the repair tool or by turning the .NET Framework features off and on.

    0 comments No comments