System (ntoskrnl.exe) high CPU usage on Windows 11

ivall pl 5 Reputation points
2023-05-20T08:51:38.57+00:00

Hi,

since yesterday System (ntoskrnl.exe) task uses about 30% - 50% of my CPU. I've already tried doing clean boot, but it didn't help. Turning off windows search and scanning for viruses too didn't help.

My version of Windows 11: 25314.rs_prerelease.230303-1411

What I can do?

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,935 questions
0 comments No comments
{count} vote

4 answers

Sort by: Most helpful
  1. S.Sengupta 17,141 Reputation points MVP
    2023-05-21T02:23:09.66+00:00

    Click the Start menu. Then type cmd in the search box. Right-click Command Prompt and choose Run as administrator.

    When you get into Command Prompt, input sfc /scannow and press Enter.

    Open the command prompt as administrator, type the command below and hit enter:

    DISM /Online /Cleanup-Image /RestoreHealth /Source:ISOmountpath\install.wim

    [source iso =win 11 iso]

    0 comments No comments

  2. ivall pl 5 Reputation points
    2023-05-21T09:30:07.76+00:00

    Hi, @S.Sengupta

    sfc didn't help (nothing found) and instead of restorehealth I've used checkhealth and scanhealth, nothing found too.

    0 comments No comments

  3. ivall pl 5 Reputation points
    2023-05-21T11:09:47.9166667+00:00

    I fixed this issue by causing system crash (stack crash and kernel).

    Also 2 days ago I wanted to cancel installing game from xbox app and it got bugged - I think since that time system task used 30-50% CPU. After system crash game got installed and issue got fixed xD


  4. Patrick Herrera 0 Reputation points
    2024-04-14T23:01:18.5566667+00:00

    This is has been occurring on my work laptop for the past few months, to which I do not have admin rights.

    No answer I've found on the internet has helped (those few that can be executed without admin rights anyway).

    However, if I unplug from mains power and work from battery (with battery saver disabled or enabled, it makes no difference), ntoskrnl.exe CPU usage instantly goes down to practically zero and I can enjoy the blessed silence of no fan running constantly.

    Obviously something changes its behaviour when on battery - I'm guessing virus scanning or search indexing pauses, which are the two most common suggestions.

    I live in hope that an update fixes the problem (that was probably caused by an update!)

    0 comments No comments