7362 Publishing Cache

Tevon2.0 931 Reputation points

Saw this error in the Event viewer but I'm not sure how to fix it.

"Object Cache: The super user account utilized by the cache is not configured. This can increase the number of cache misses, which causes the page requests to consume unneccesary system resources.

To configure the account use the following command 'stsadm -o setproperty -propertyname portalsuperuseraccount -propertyvalue account -url webappurl'. The account should be any account that has Full Control access to the SharePoint databases but is not an application pool account.

Additional Data:

Current default super user account: SHAREPOINT\system"

SharePoint Server
SharePoint Server
A family of Microsoft on-premises document management and storage systems.
1,796 questions
Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
7,484 questions
SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,504 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Ling Zhou_MSFT 1,100 Reputation points Microsoft Vendor

    Hi @Tevon2.0 ,

    The object cache stores properties about items in SharePoint Server. The object cache makes its queries as one of two out-of-box user accounts: the Portal Super User and the Portal Super Reader. The Portal Super User and Portal Super Reader accounts must be separate accounts, and they must not be accounts that will ever be used to log in to the site. By default, the Portal Super User account is the site's System Account, and the Portal Super Reader account is NT Authority\Local Service. But using an existing account can pose problems:

    1. The first issue is that some items get checked out to System Account, so when a query that includes these items is made, the checked out version of the item is returned instead of the latest published version. The same problem would occur for any user who has items checked out, if that user's account was set to be the Portal Super User account. 
    2. The default Portal Super Reader account is NT Authority\Local Service, which is not correctly resolved in a claims authentication application. As a result, if the Portal Super Reader account is not explicitly configured for a claims authentication application, browsing to site collections under this application will result in an "Access Denied" error, even for the site administrator.

    So, I suggest you configure your own user account for the object cache by the SharePoint Central Administration website and Microsoft PowerShell. Before you start, please note:

    At the end of this procedure, you must reset Internet Information Services (IIS) to apply the changes to the web application. Be sure to perform this procedure when there will be minimal disruption to users that are connected to the site. 

    The configuration is divided into three steps:

    1. Create the user accounts by using Central Administration.
    2. Add the user accounts to the web application by using Microsoft PowerShell.
    3. Reset Internet Information Services (IIS).

    The link is a detailed step-by-step on the configuration, see: Configure object cache user accounts in SharePoint Server - SharePoint Server | Microsoft Learn

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. Limitless Technology 26,326 Reputation points


    I'd be happy to help you out with your question. Sorry for the inconvenience caused.

    To fix this, you will need to configure the super user account. You can do this using the following command:

    stsadm -o setproperty -propertyname portalsuperuseraccount -propertyvalue account -url webappurl

    The account parameter should be the name of an account that has full control access to the SharePoint databases. The webappurl parameter should be the URL of the web application where you want to configure the super user account.

    Once you have run this command, the error message should go away and SharePoint should be able to access the object cache more efficiently.

    Here are some additional details about the super user account:

    • The super user account must have full control access to the SharePoint databases.
    • The super user account cannot be an application pool account.
    • The super user account does not need to be a user that exists in Active Directory. You can create a local account for this purpose.

    For more Information, please refer to following resource :-

    Configure object cache user accounts in SharePoint Server - https://learn.microsoft.com/sharepoint/administration/configure-object-cache-user-accounts

    If you have any other questions or need assistance with anything, please don't hesitate to let me know. I'm here to help.

    If the reply was helpful, please don’t forget to upvote or accept as answer, thank you.

    0 comments No comments

  3. Limitless Technology 26,326 Reputation points

    Hello there,

    Use RSoP to identify the specific User Rights, Restricted Groups, and Source GPOs that contain the problem accounts:

    a. Start -> Run -> RSoP.msc

    b. Review the results for Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment and Computer Configuration\Windows Settings\Security Settings\Local Policies\Restricted Groups for any errors flagged with a red X.

    c. For any User Right or Restricted Group marked with a red X, the corresponding GPO that contains the problem policy setting is listed under the column entitled "Source GPO". Note the specific User Rights, Restricted Groups and containing Source GPOs that are generating errors.

    Similar discussion here


    Hope this resolves your Query !!

    --If the reply is helpful, please Upvote and Accept it as an answer--