Purview Updating Entity, Assets column, description etc

Jadhav, Karan 10 Reputation points
2023-05-24T15:14:22.88+00:00

Hello,

I am trying to update an entity in Azure Purview from Spark Notebook or through Postman. We have a default purview setup in Azure. However, through both ways I am able to fetch the data but I am unable to post anything. 

Following are the POST API calls that I have tried :

https://{{purview_acc_name}}.catalog.purview.azure.com/api/atlas/v2/entity/

https://{{purview_acc_name}}.catalog.purview.azure.com/api/atlas/v2/entity/bulk/

The error I receive always is : {"error":{"code":"Unauthenticated","message":"Token expired"}}
I also tried creating a new token and it hits the API correctly but just not able to authenticate the token.

There is already several discussions on it without any concrete solution : 

  1. One solution was to check Content-Type, I tried out by selecting JSON as well(https://techcommunity.microsoft.com/t5/microsoft-purview/create-entity-api/m-p/3549161))
    2. https://techcommunity.microsoft.com/t5/microsoft-purview/adding-custom-properties-to-an-entity-in-pu...
    3. https://techcommunity.microsoft.com/t5/microsoft-purview/api-to-azure-purview/m-p/3602951#M313

Documentation reference : 
https://learn.microsoft.com/en-us/rest/api/purview/catalogdataplane/entity/create-or-update?tabs=HTT...
https://learn.microsoft.com/en-us/rest/api/purview/catalogdataplane/entity/create-or-update-entities...

Can you please let me know, if there is a solution to this issue.

Thanks & Regards,
Karan token_issue

Microsoft Purview
Microsoft Purview
A Microsoft data governance service that helps manage and govern on-premises, multicloud, and software-as-a-service data. Previously known as Azure Purview.
1,056 questions
{count} votes

1 answer

Sort by: Most helpful
  1. PRADEEPCHEEKATLA-MSFT 85,351 Reputation points Microsoft Employee
    2023-05-29T06:45:50.4166667+00:00

    @Jadhav, Karan - Thanks for the question and using MS Q&A platform.

    There could be two reason, for the above issue - you are using the expired access_token or the client_secret has been expired. Make sure to validate both and see if that works.

    As per the repro from my end, I was experiencing the same issue because I was using the access_token which is generated on the last use (almost a month ago).

    User's image

    When I replaced with the new access_tokenwith a newer access_token it working as excepted.

    MSPurviewRestUpload

    There could be another issue which would leads to this error message, that can be client_secret expired. Make sure that you have a valid client_secret incase, if it expired try to create a new client_secret and re-generate the token.

    User's image

    Hope this helps. Do let us know if you any further queries.


    If this answers your query, do click Accept Answer and Yes for was this answer helpful. And, if you have any further query do let us know.