Why do local mapped drives keep asking for credentials?

Mikros476 45 Reputation points
2023-05-25T20:21:46.9733333+00:00

For two of our users, a mapped drive (N:) to a server on our local network keeps requiring password credentials after either a reboot or sleep or just after a while. It's weird. When mapping them with net use I used the /persistent:yes flag after providing the credentials. And even when it asks for the password in the UAC window, they click remember, but it doesn't seem to. I checked in Credential Manager and the password is stored with Enterprise persistence. I also checked some of the relevant Group Policy settings and they look ok. Is there something else to consider here? This is Windows 11 on a Dell Precision laptop. I also notice the File Explorer is very slow to load initially, but becomes ok if you restart the process in Task Manager.

The same symptoms occur in two of our laptops but others of the same model and setup don't seem to have these issues.

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,937 questions
{count} vote

1 answer

Sort by: Most helpful
  1. Limitless Technology 44,101 Reputation points
    2023-06-01T10:22:19.4733333+00:00

    Hello there,

    An incorrectly-set Advanced Sharing setting is one of the most common causes of this error. Ideally, your PC should be allowed to manage homegroup connections. You can also use the Advanced Sharing settings page to disable password-protected sharing, which will allow you to share files without needing to log in.

    Use credential manager in Windows to remember the username and password for your Drive if it doesnt remember it automatically.

    Go to Start ⇒ Control Panel ⇒ User Accounts and Family Safety ⇒ Credential Manager

    On the right hand side, right below where it says "Windows Credentials" Select "Add a Windows Credential".

    Enter your Server name or IP in the first box.

    Hope this resolves your Query !!

    --If the reply is helpful, please Upvote and Accept it as an answer–