Azure Virtual Desktop Session Host Showing black screen with flashing taskbar after every fresh deployment

Ronald Allan Drilon 6 Reputation points
2023-05-29T08:04:51.0666667+00:00

Howdy Azure Squadron!

After each fresh deployment of Azure Virtual Desktop, the session host is only showing a black screen with flashing taskbar looping infinitely when remote accessing it and I could not click anything. I have deployed many times with different configurations and the issue is still happening. Below are the details.

Date and time issue started happening: Friday, May 25, 2023, 11 pm Pacific Standard Time (PST)

I have tried the following with the same issue still happening.

  1. Deployed to different Azure regions such as West US 3, West US, Australia East
  2. Deployed using different Windows 10 and Windows 11 enterprise multi session images such as 20h2, 21h2, 22h2 with or without Office apps
  3. Tried using the AVD web client and the AVD Remote Desktop client.

I am using the following AVD link when using a browser:

AVD Link #1 (For common AVD): https://client.wvd.microsoft.com/arm/webclient/

AVD Link #2 (For classic AVD): https://client.wvd.microsoft.com/webclient/index.html

Here's the Remote Desktop client software that I'm using for remote accessing the AVDs

https://go.microsoft.com/fwlink/?linkid=2139369

I could not go inside the desktop of the session host because of the issue.

I have deployed many fresh AVDs previously and this issue is not happening, so I checked the Azure health. Upon checking I could not see any issue in Azure health.

I didn't tried to remote access the session host Virtual Machine using RDP with a public IP, since this issue is not the default behavior of a freshly deployed Azure Virtual Desktop. I would have tried to fix this, if this is a mission critical Virtual Machine that many users are using in prod, on the other hand this is just a test machine that I could delete and recreate before deploying it to prod, however because of this issue, deleting and recreating it still produces the same issue on every fresh deployment I made and I could not even test the AVD deployment.

Here are the links for the screen grab video files showing the issue.

Web browser client: https://ufile.io/clnwwzra

Remote Desktop client: https://ufile.io/nsomnfxa

Thank you very much for your help.

Azure Virtual Desktop
Azure Virtual Desktop
A Microsoft desktop and app virtualization service that runs on Azure. Previously known as Windows Virtual Desktop.
1,449 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Ronald Allan Drilon 6 Reputation points
    2023-06-03T10:32:52.33+00:00

    To those who are having the same issue, uninstalling FSLogix fixed the issue. However, this is just a workaround. I think AVD should work without any errors when you freshly deploy it. Have a great day.

    1 person found this answer helpful.

  2. Prrudram-MSFT 23,131 Reputation points
    2023-05-29T09:48:18.0733333+00:00

    Hello @Ronald Allan Drilon

    I cannot access any of the links in the question posted to check on the behavior. 

    Nevertheless, please use only the AVD Link #1, the classic won't work for Arm-based AVD deployments. For Windows, please use the latest GA client version from here https://learn.microsoft.com/en-us/azure/virtual-desktop/whats-new-client-windows?toc=%2Fazure%2Fvirtual-desktop%2Fusers%2Ftoc.json#updates-for-version-124240

    Did you use a marketplace image, or a custom image?

    Do you use FSlogix profiles or local profiles?

    Is the VM domain joined? If yes, please verify the OU and GPOs that you might apply to the VM.

    If this does answer your question, please accept it as the answer as a token of appreciation.