Published App on Remote Desktop Connection Broker

Genesis Support 301 Reputation points
2023-05-31T09:54:19.48+00:00

Hi,

I've successfully published the Word app on my 2016 Remote Desktop Connection Broker with a Windows 2016 Session Host Server. My users can now use the published Word app without any problems.

However when they try to save the file, it doesn't give them the option to save to the local PC of which they are working on...

Instead, it tries to save it to the Session Host server in the users profile C:\User\TestUser and not the PC by which the user has launched the publish app.

Is there a workaround or a solution such that when the user launches the published app on their PC, it gives them the option to save on their PC as oppose to the remote Session Host Server (hosting the app)?

Many Thanks

GMSS

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,383 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Limitless Technology 44,096 Reputation points
    2023-06-02T12:36:15.38+00:00

    Hello,

    Thank you for your question and for reaching out with your question today.

    The process to change the default save location is the same for all Office apps, including Word, Excel, and PowerPoint. Also, if you make one Office app save files to your local computer, all other apps automatically start saving files locally on your machine as well.

    Here’s how you make that change in Word (which will auto-apply to all other Office apps):

    Launch Microsoft Word on your computer.

    Select Options from the left sidebar. If you’re on Word’s editing screen, select File > More > Options instead.

    Select Save in the sidebar on the left of the Word Options window.

    Enable the Save to Computer by default option in the Save documents section on the right.

    Save your changes by selecting OK at the bottom of the window.

    If the reply was helpful, please don’t forget to upvote or accept as answer.

    Best regards.

    0 comments No comments

  2. Genesis Support 301 Reputation points
    2023-06-07T09:37:24.68+00:00

    Hi,

    Thanks for your reply. I understand how to save a file but that is not the issue unfortunately.
    I've now managed to work it out and this is what I've done to make this work. In essence the solution was in the RD Gateway Manager:

    1. Open RD Gateway Manager
    2. Drill down to Policies --> Connection authorization Policies
    3. Click on the Policy related to the RD Gateway Server by where you specify users who can connect.
    4. Next, Click on the device Redirection tab
    5. Select "Enable device redirection for all client devices" and Click on OK

    RDGateway

    Hope this would help someone else who is also experiencing the same problem.

    Kind Regards

    GMSS

    0 comments No comments