Windows defender/security app isn't starting

David Dayanidhi 0 Reputation points
2023-06-01T14:49:43.1666667+00:00

I installed a game from web and the installation required I turn off all protection from windows defender. I turned them all off and apparently the installation disabled or deleted some link required to open the defender app. I uninstalled the game completely and wanted to reinstate the defender. But it is not opening. It says "You'll need a new app to open this windowsdefender link"

How can I get the defender up again!!!

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
11,159 questions
Windows 10 Security
Windows 10 Security
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Security: The precautions taken to guard against crime, attack, sabotage, espionage, or another threat.
2,837 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Reza-Ameri 16,861 Reputation points
    2023-06-02T18:56:58.4366667+00:00

    Try open the Command prompt as administrator and then type the following command:

    sfc /scannow

    Press enter and let it runs and see if that solve the problem.

    If not , then open start and search for Settings and open it and go to Apps and select Apps & features and from list find the Windows Security, click on ... and select Advanced options and press Reset and let it complete the operation.

    Then restart your PC and see if that solved the problem.


  2. Reza-Ameri 16,861 Reputation points
    2023-06-03T15:41:44.9833333+00:00

    Try open command prompt as administrator and then type the following command:

    Sfc /scannow
    DISM /Online /Cleanup-Image /StartComponentCleanup
    DISM /Online /Cleanup-Image /RestoreHealth

    If not, the run the following command:

     PowerShell -ExecutionPolicy Unrestricted -Command "& {$manifest = (Get-AppxPackage Microsoft.Windows.SecHealthUI).InstallLocation + '\AppxManifest.xml' ; Add-AppxPackage -DisableDevelopmentMode -Register $manifest}"