Issue with Row-Level Security not applying filters in Azure Analysis Services Data Model

Abishek Kumar 0 Reputation points
2023-06-05T10:53:26.03+00:00

I am currently developing a Data Model in Azure Analysis Services using Visual Studio and have implemented Row-Level Security (RLS) to restrict access based on users' email addresses. However, when I test RLS in SQL Server Management Studio from the end user's perspective, I do not observe any filters being applied.

To provide some context, here are the steps I followed to develop and test RLS:

  1. Using Visual Studio, I developed RLS and applied it to a table, restricting access based on users' email addresses and granting read-only access. I utilized an Azure Active Directory group to manage membership, ensuring that only users with specific email addresses can access records filtered by their email IDs.

VisualStudioRLS

  1. After deploying the model to Analysis Services, I proceeded to test the Cube in SQL Server Management Studio. I utilized the browse function and selected a user from the Azure Active Directory group through the Change User option.

select user

However, when I attempt to browse the data, I still see all the data instead of the filtered results. For instance, even when trying to view the email column, which is included in the RLS filter, I observe all email records.

I have successfully worked with RLS in Power BI models using the same RLS filter and Azure Active Directory group, where it functions as expected. However, I am encountering difficulties in achieving the same outcome with Analysis Services.

I would greatly appreciate any assistance provided.

Thank you!

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
37,573 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Abishek Kumar 0 Reputation points
    2023-06-09T09:48:35.8633333+00:00

    Solved the issue. The group was given Admin right for the Azure analysis services.

    0 comments No comments