JDBC\ODBC connection to Azure Dataricks fails

Rajesh 36 Reputation points
2020-10-19T12:22:43.827+00:00

Hi,

I referred the following links in net and tried all, but still I am not connecting to Azure Databricks database

https://docs.databricks.com/integrations/bi/power-bi.html
https://docs.databricks.com/integrations/bi/jdbc-odbc-bi.html
https://learn.microsoft.com/en-us/azure/databricks/scenarios/connect-databricks-excel-python-r
https://learn.microsoft.com/en-us/azure/databricks/kb/bi/jdbc-odbc-troubleshooting
https://www.sqlshack.com/connect-azure-databricks-data-to-power-bi-desktop/
https://medium.com/@mauridb/powerbi-and-azure-databricks-193e3dc567a

I am getting the below errors

Trying from DBVisualizer getting the below error
[Simba][SparkJDBCDriver] Communication link failure. Failed to connect to server. Reason: HTTP Response code: 401, Error message: Unknown.

Trying from Postman getting the below error
javax.servlet.ServletException: org.apache.thrift.transport.TTransportException

When testing the ODBC connection during System DSN setup getting the below error
[Simba][ThriftExtension] (14) Unexpected response from server during a HTTP connection: SSL_connect: certificate verify failed.

Trying from MS Power BI getting the below error
"ODBC: ERROR [HY000] [Microsoft][DriverSupport] (1170) Unexpected response received from server. Please ensure the server host and port specified for the connection are correct."

Any help would be appreciated

Azure Databricks
Azure Databricks
An Apache Spark-based analytics platform optimized for Azure.
1,853 questions
0 comments No comments
{count} votes

4 answers

Sort by: Most helpful
  1. Venkat Indrakanti 11 Reputation points
    2022-05-05T18:25:35.117+00:00

    I got it to work by enabling SSL, checking "Use Trusted store" and unchecking "Check Certificate Revocation"
    199353-image.png

    2 people found this answer helpful.

  2. PRADEEPCHEEKATLA-MSFT 73,731 Reputation points Microsoft Employee
    2020-10-20T07:50:12.363+00:00

    Hello @Rajesh ,

    Welcome to Microsoft Q&A platform.

    Note: JDBC or ODBC driver is not required to install on your local machine.

    Make sure you have followed the steps mentioned in the document.

    Here are the steps to connect Azure Databricks using Power BI Desktop.

    Step 1: Get Azure Databricks connection information.

    Go to Clusters => Configuration => Advanced Options => JDBC/ODBC

    Copy Server Hostname & HTTP Path.

    33536-image.png

    Step 2: Configure Azure Databricks cluster connection in Power BI

    1. In PowerBI Desktop, go to Get Data > Azure and select the Azure Databricks connector.
    2. Click Connect.

    33558-image.png

    1. Paste the Server Hostname and HTTP Path you retrieved in Step 1.
    2. Select your Data Connectivity mode.
    3. Click OK.

    33582-image.png

    1. At the authentication prompt, select the way you want to log in to Azure Databricks:
    2. Azure Active Directory: Use your Azure account credentials. Click the Sign in button. In the sign-in dialog, enter your Azure account username (email, phone, or Skype).
    3. Click Connect.
    4. Select the Azure Databricks data you want to query from the Power BI Navigator

    33458-image.png

    Hope this helps. Do let us know if you any further queries.

    ------------

    • Please accept an answer if correct. Original posters help the community find answers faster by identifying the correct answer. Here is how.
    • Want a reminder to come back and check responses? Here is how to subscribe to a notification.

  3. Brian McCully 1 Reputation point
    2022-02-17T04:46:41.693+00:00

    ok everyone, stumbled on the solution in a QuikView solutions page. if using the ODBC connector, click on the SSL button at the bottom right and enable....SUCCESS!.

    "ODBC: ERROR [HY000] [Microsoft][ThriftExtension] (14) Unexpected response from server during a HTTP connection: SSL_connect: certificate verify failed.

    0 comments No comments

  4. Lars Fiedler 1 Reputation point
    2022-03-30T15:27:35.753+00:00
    0 comments No comments