SharePoint - missing "Edit" feature on some pages but not others

Katie 0 Reputation points
2023-07-12T17:47:35.02+00:00

I am working on a SharePoint page andOn the original SharePoint, the edit feature is visible next to "share" and "follow", however on the copied over version, the edit feature is not there.

I was able to edit the content of the page by clicking the settings icon and selecting "edit page", however I cannot figure out how to adjust the layout or move around the content I have added.

I think I found on here that the reason the "edit" button is missing is because it is considered a "publishing portal" site, however I am not sure how to change this/what would change if it is not a publishing portal page anymore.

I am just wondering how to be able to edit the page layout (have two sections on the page so that "quick links" can be off to the side) without the "edit" button being there, or how to get the "edit" button to appear next to "share" and "follow".

SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
9,169 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Ling Zhou_MSFT 11,700 Reputation points Microsoft Vendor
    2023-07-13T06:09:44.2133333+00:00

    Hi @Katie,

    Thank you for posting in this community.

    I tested your question in my side. I found that edit button does not appear on the published page. Is it possible that the page you are modifying is published?

    Before publication:

    User's image

    After publication:

    User's image

    We can't add an edit link or button to the published page because if the published page has an edit button or link, then the page content can be changed at any time and the point of publishing is lost.

    Perhaps you can only modify the page layout by clicking the settings button and selecting the Edit Page button. Under the page area there has a page layout option.

    User's image


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Katie 0 Reputation points
    2023-07-17T13:36:53.5666667+00:00

    I do not see a "page layout" option when I got into "edit page" through settings. I am guessing this is due to the fact that it is already published (the link just has not been shared with people as we are still editing the contents). Is there any way to un publish the page so that I can edit the layout?

    screenshot no page layout

    0 comments No comments

  3. Ling Zhou_MSFT 11,700 Reputation points Microsoft Vendor
    2023-07-18T05:21:27.5033333+00:00

    Hi @Katie,

    Thank you for the reply.

    If you do not see a "page layout" option when you got into "edit page" through settings, then I am afraid your SharePoint Server Publishing Infrastructure feature and SharePoint Server Publishing feature are not turned on.

    1. Please click the settings button and select Site contents->site Settings. Go to top level site settings->Site Administration->site collection features->SharePoint Server Publishing Infrastructure. Activate this feature. User's image
    2. Please click the settings button and select Site contents->site Settings ->Site Actions->Manage site features->SharePoint Server Publishing. Activate this feature. User's image

    After activating both features, clear your browser cache and then check to see if the page layout options appear on the page area.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.