My Python app runs locally. I deploy it via Github but it doesn't run?

Sean 0 Reputation points
2023-07-15T12:56:15.89+00:00

This is my first Python App deployment and first time using Azure.

My app runs locally. I use VS Code to deploy via GitHub. It shows as deployed. Yet I still get the Welcome screen when I visit the app URL.

If I FTPS from my PC I just see a newly created output.tar.gz (date and timestamp matches deployment) file, the hostingstart.html and oryx-manifest.toml.

I have tried to just manually place my files in the root but it still doesn't run.

Have I missed a configuration or set-up step?

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
6,490 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Sean 0 Reputation points
    2023-07-18T10:37:56.8733333+00:00

    Resolved: For any other noobs out there. When I created my Python script I gave it a custom name. So running it locally I was calling that name.

    I overlooked the fact that app.py is the default that Azure would look for. I renamed my script (I know I could have changed the config), to app.py and it runs.

    Thanks for everyone's time.