High CPU from System Center Endpoint Protection and Windows Defender

Duchemin, Dominique 2,006 Reputation points
2023-07-18T16:13:07.1366667+00:00

Hello,

I have System Center Endpont Protection installed on all servers.

I have Windows Defender feature installed on Windows Server 2016, Windows Server 2019, Windows Server 2022 and all Desktops.

How could I permanently limit the CPU usage to 10-15%? not only during SCAN as apparently the settings are just impacting the scans but the CPU is high even at other time ... not sure which other process(es) than the scan starts this service.

2023-07-18_9-17-56 OISSANDYMLT.jpg

Thanks,
Dom

Microsoft System Center
Microsoft System Center
A suite of Microsoft systems management products that offer solutions for managing datacenter resources, private clouds, and client devices.
755 questions
Windows Server Security
Windows Server Security
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.Security: The precautions taken to guard against crime, attack, sabotage, espionage, or another threat.
1,684 questions
Microsoft Configuration Manager
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. XinGuo-MSFT 12,706 Reputation points
    2023-07-19T06:48:03.1633333+00:00

    Hi,

    Unfortunately, it's important to note that directly limiting the CPU usage of System Center Endpoint Protection or Windows Defender to a specific percentage, such as 10-15%, is not a standard configuration option. Antivirus software like System Center Endpoint Protection and Windows Defender is designed to use system resources, including CPU, to provide real-time protection and scanning capabilities.

    While you can adjust some settings to optimize resource usage, it's not advisable to forcibly limit the CPU usage of these security solutions. Doing so could compromise the effectiveness of the antivirus protection and leave your systems vulnerable to malware and other threats.

    0 comments No comments