Microsoft Defender for cloud connector dosent connect to Sentinel

Bruno Pinheiro 0 Reputation points
2023-07-22T19:33:44.98+00:00

Hello,

I'm using the lab environment: Microsoft Sentinel Training Lab Solution (Preview) to study for the sc-200 exam, I already did all the steps in the first module, but, in the second one is asked to connect the Defender for Cloud connector in Sentinel, but when I try to enable it, the configuration do not connect to my sybscription as you can see:

connector

There is no error message that indicate what is missing.

Obs:

  • The Microsoft.SecurityInsights is registred at the resource provider in the subscription.
  • There is only one subscription in this environment.
  • There is only one Sentinel worksapce and only one resource group.
  • The Defender for cloud is already enable for the subscription level.
  • The account that I'm using has Global Admin permissions (and I added the Security Admin just to be sure).
  • I already tryied to reinstall the connector.

Can someone give me some advice abou what can I do to fix this ?

This is the reference that I'm using: https://github.com/Azure/Azure-Sentinel/blob/master/Solutions/Training/Azure-Sentinel-Training-Lab/Modules/Module-2-Data-Connectors.md

Regards.

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
34,978 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Venugopal Reddy Jambula 0 Reputation points
    2023-11-06T06:37:36.8233333+00:00

    Hi Bruno,

    please read the permissions required on the subscription. go to subscriptions, IAM and add a role to user as contributer. ten try connect. it worked for me as owner of subscription

    Regards,

    Venu

    0 comments No comments