I messed up with Windows Search service

Lucas Bomjardim 0 Reputation points
2023-07-23T13:23:41.2366667+00:00

Hello everyone,

Previously, I want to apologize for my english since isn't my native language, so if someone didn't understand what I meant, please tell me and I'll try to explain in another way. Also my system isn't in english tho, so if I mispronounce some term, let me know please.

Recently, I changed my startup modes of some services, including Windows Search service which its default mode is "Automatic (Delay on Startup)" and I changed it to "Automatic".

My problem is: I cant use Windows Explorer because keeps crashing every time I open it up. I looked into services.msc and the the service Windows Search (service necessary to explorer functions) ins't started. When I try to manually start the service, I get:
Error 1722: RPC Server is unavailable
But I checked and all RPC services are running normally.

In Safeboot (Minimal) all works fine.

I already tried to use default services configurations but without success.

Anyone has idea about what is happening?

Ps. I recently turned off my BitLocker because was lagging my startup and causing conflicts with my Linux dualboot.

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
7,641 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. S.Sengupta 14,441 Reputation points MVP
    2023-07-24T01:04:02.9666667+00:00

    Open Command Prompt as Administrator and copy paste the following commands followed by hitting the Enter key:

    DISM/Online/Cleanup-Image/RestoreHealth

    SFC /scannow

    Microsoft references:

    Repair a Windows Image

    Use the System File Checker tool to repair missing or corrupted system files

    0 comments No comments

  2. Karlie Weng 12,606 Reputation points Microsoft Vendor
    2023-09-11T07:32:27.08+00:00

    Hello Lucas Bomjardim

    Did you check RPC Service Dependencies, are they running correctly?

    User's image

    0 comments No comments