VM agent status is not ready

Nick Johnson 60 Reputation points
2023-07-24T13:03:26.2433333+00:00

VM is successfully connected to the fslogix service and the Fslogix service is installed, then the registry is set in V M then V M prompt to shutdown or restart, and I have chosen to shutdown V M, After that try to connect V M but does not connect. And the error showing that the error VM agent status is not ready, troubleshooting this problem.please find the error screenshot for your refrence.

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
6,807 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Monalla-MSFT 9,681 Reputation points
    2023-07-31T17:34:17.75+00:00

    @Nick Johnson - Thanks for reaching out to us and apologies for the delay in responding to your query.

    Have you tried reinstalling the agent/update the agent yet?

    If not, check to see if below helps.

    1. Go to Portal > Settings > Extensions and ensure all extensions are in provisioning succeeded state.
    2. If the extensions are in provisioning succeeded state, check if the agent is installed and running. For Windows VMs, you can check the status of the agent in the Services console. For Linux VMs, you can check the status of the agent by running the command "sudo service waagent status".
    3. If the agent is not running, you can try restarting it. For Windows VMs, you can restart the agent by running the command "net stop waagent" followed by "net start waagent". For Linux VMs, you can restart the agent by running the command "sudo service waagent restart".
    4. If the agent is running but still unresponsive, you can try updating it to the latest version. For Linux VMs, you can update the agent by running the command "sudo waagent -install". For Windows VMs, you can download and install the latest version of the agent from the Microsoft Download Center.

    Hope this helps. and please feel free to reach out if you have any further questions.


    If the above response was helpful, please feel free to "Accept as Answer" and click "Yes" so it can be beneficial to the community.

    0 comments No comments