Can't deploy Azure Open AI models due "No quota is available for this deployment. You can request for more quota."

Srijith S 20 Reputation points
2023-07-31T18:19:44.3766667+00:00

I wanted to test a new model, so I attempted to deploy it. However, I received "No quota is available for this deployment. You can request for more quota." error message. I initially assumed that it might be due to a couple of existing deployments like text-davinci-003 model, so I deleted two of them and waited for more than 48 hours so that the quota is released. Unfortunately, I encountered the same issue even after removing the previous deployment(facing this issue since last week). I have RG level access.

I requested somebody with Sub level access and he didn't get the error prompt. Please help!

Azure OpenAI Service
Azure OpenAI Service
An Azure service that provides access to OpenAI’s GPT-3 models with enterprise capabilities.
1,882 questions
Azure AI services
Azure AI services
A group of Azure services, SDKs, and APIs designed to make apps more intelligent, engaging, and discoverable.
2,221 questions
{count} votes

Accepted answer
  1. AshokPeddakotla-MSFT 25,531 Reputation points
    2023-08-01T05:07:07.2233333+00:00

    Srijith S Greetings & Welcome to Microsoft Q&A forum!

    I wanted to test a new model, so I attempted to deploy it. However, I received "No quota is available for this deployment. You can request for more quota." error message. I initially assumed that it might be due to a couple of existing deployments like text-davinci-003 model, so I deleted two of them and waited for more than 48 hours so that the quota is released. Unfortunately, I encountered the same issue even after removing the previous deployment(facing this issue since last week). I have RG level access.

    You have mentioned you had waited for more than 48 hours, did you try once purging a deleted resource? Once you delete a resource, you won't be able to create another one with the same name for 48 hours. To create a resource with the same name, you will need to purge the deleted resource. See Purge a deleted resource for more details.

    I requested somebody with Sub level access and he didn't get the error prompt. Please help!

    First check if you have the "Cognitive Services OpenAI Contributor" role is enabled or not. If not, follow the below steps.

    To enable "Cognitive Services OpenAI Contributor" role, Goto Azure Open AI resource in Azure Portal -> Access control (IAM) -> Add role assignment --> Select "Cognitive Services OpenAI Contributor" role and assign.

    Please see below for more clarity.

    User's image

    User's image

    Once you have added the role assignment, you will be able to see this under View My access tab.

    User's image

    Also, User needs to be a reader at the Subscription level and should have Cognitive Services OpenAI Contributor on the resource level to work. You can check the list of actions available and assign the roles.

    Hope this resolves your issue. Do let me know if you have any further queries.


    If this answers your query, do click Accept Answer and Yes for was this answer helpful. And, if you have any further queries do let us know.

    1 person found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. Q&A Assist
    2023-07-31T18:19:44.38+00:00
    AI generated content. This question contains an answer created with AI from Q&A Assist. Learn more

    It seems like you are trying to deploy a new model in Azure OpenAI but you are getting the error message "No quota is available for this deployment. You can request for more quota". This message indicates that you do not have enough quota assigned to your subscription to deploy this new model. This can happen even if you have deleted some of the previous deployments as the quota allocation remains tied up for 48 hours after a resource is deleted.

    To resolve this issue, you can follow the steps to manage your Azure OpenAI service quota which can be found in the documentation titled "Manage Azure OpenAI Service quota" [1]. Ensure that you have the required permissions to manage quota as mentioned in the "Prerequisites" section of the same documentation [1]. Once you have the required permission, you can manage your quota allocations as per your needs.

    If you believe you have enough quota allocated for the new model deployment, but you are still getting this message, you can follow the troubleshooting steps outlined in the documentation titled "Troubleshooting online endpoints deployment and scoring" [2]. This document outlines some common issues that cause failures during online endpoint deployment and scoring, including those related to capacity and quota issues.

    References:

    1. Manage Azure OpenAI Service quota: https://learn.microsoft.com/en-us/azure/ai-services/openai/how-to/quota
    2. Troubleshooting online endpoints deployment and scoring: https://learn.microsoft.com/en-us/azure/machine-learning/how-to-troubleshoot-online-endpoints?view=azureml-api-2#common-deployment-errors
    1 person found this answer helpful.
    0 comments No comments