VPS connection problem

Gienkoskyy 0 Reputation points
2023-07-31T23:50:00.9166667+00:00

hello, I have a problem with connecting to the VPS, when installing the server on cs 1.6, it was impossible to connect, I entered the following commands: systemctl stop ufw, systemctl stop firewalld, Iptables -F, and then it worked, unfortunately, when installing another thing, the machine turned off again in the sense that it was impossible to enter through port 22, I type the same commands, and it tells me I don't have permissions, I try to give sudo or sudo su before that and still no.
Version: Ubuntu latest
The error that pops up:

bbuser@BaseBuilder:/root$ systemctl stop ufw ==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units === Authentication is required to stop 'ufw.service'. Authenticating as: Ubuntu (bbuser) polkit-agent-helper-1: needs to be setuid root Error: Incorrect permissions on /usr/lib/policykit-1/polkit-agent-helper-1 (needs to be setuid root) ==== AUTHENTICATION FAILED === Failed to stop ufw.service: Access denied See system logs and 'systemctl status ufw.service' for details.
Not Monitored
Not Monitored
Tag not monitored by Microsoft.
35,061 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Sedat SALMAN 12,505 Reputation points
    2023-08-01T04:51:12.5766667+00:00

    the following can be a solution according to the error

    add abuser to the sudoers group

    add line 
    bbuser ALL=(ALL:ALL) ALL
    

    check the sudo configuration as bbuser if there is an issue

    sudo -l
    

    The error message mentions that /usr/lib/policykit-1/polkit-agent-helper-1 needs to be 'setuid root'. Change this by

    chmod u+s /usr/lib/policykit-1/polkit-agent-helper-1
    
    0 comments No comments

  2. Gienkoskyy 0 Reputation points
    2023-08-01T16:23:17.25+00:00

    @Sedat SALMAN Where should I type this command, because something like this pops up

    
    
    bbuser@BaseBuilder:/$ add line 
    
    Command 'add' not found, did you mean:
    
      command 'hadd' from snap root-framework (v6-28-04)
      command 'adb' from deb adb (1:8.1.0+r23-5ubuntu2)
      command 'pdd' from deb pdd (1.4-2)
      command 'ad' from deb netatalk (3.1.12~ds-4ubuntu0.20.04.1)
      command 'tdd' from deb devtodo (0.1.20-7build1)
      command 'ddd' from deb ddd (1:3.3.12-5.2build1)
      command 'amd' from deb am-utils (6.2+rc20110530-3.2ubuntu2)
      command 'ldd' from deb libc-bin (2.31-0ubuntu9.9)
      command 'atd' from deb at (3.1.23-1ubuntu1)
      command 'axd' from deb afnix (2.9.2-2build1)
      command 'dad' from deb debian-dad (1)
      command 'dd' from deb coreutils (8.30-3ubuntu2)
      command 'aid' from deb id-utils (4.6+git20120811-4ubuntu2)
    
    See 'snap info <snapname>' for additional versions.