Using "Add your data" in Azure OpenAI results in "Access denied due to Virtual Network/Firewall rules." when in a VNet and filtering by IP in the Firewall

Jorge Fernando 5 Reputation points

I'm trying to use the "Add your data" feature in the Azure OpenAI chat playground, but I'm currently facing an issue when having the OpenAI service in a VNet together with IP filtering in the Firewall.

Every time I try to add my data, it results in a "Access denied due to Virtual Network/Firewall rules." error. Both my Cognitive Search Service and Blob Storage are configured to allow public access from all networks.

The issue seems to be the fact that the OpenAI service is in a VNet, and using IP filtering in the Firewall. If I change the service to also be public, the feature works correctly. I've tried adding the Cognitive Search Service and Blob Storage into the same VNet, but the issue remains.

What configuration am I missing here? Some extra VNet configuration, or adding a range of IPs to the Firewall? And if so, where can I retrieve said IPs?

Thank you.

Azure OpenAI Service
Azure OpenAI Service
An Azure service that provides access to OpenAI’s GPT-3 models with enterprise capabilities.
1,871 questions
{count} vote

1 answer

Sort by: Most helpful
  1. VasaviLankipalle-MSFT 11,296 Reputation points

    Hello @Jorge Fernando , Thanks for using Microsoft Q&A Platform.

    This is a known issue. For suppose if you turn on VNet on a resource, it means that resource can only be accessed via the VNet and not from any other network. But the VNet/Firewall/Private Endpoint for "add your data" feature is not supported as of now. So, the resource has to be on a public network (no private endpoint/VNet):

    The product team is already working on this, and we don't have any ETA to share with you when this is supported. Will let you know if we hear anything.

    I hope this helps.


    -Please kindly accept the answer and vote 'yes' if you feel helpful to support the community, thanks.

    1 person found this answer helpful.