Demoted DC unable to RDP after DNS change

RawatP 61 Reputation points
2020-10-21T20:27:42.333+00:00

So we have demoted one of Windows 2012 R2 DC server and changed its primary DNS ip from loopback ip to DNS server IP.
Now we are not able to RDP of the server. It is in the network and RDP services seems running well for the server.
This is also our terminal licensing server.

Windows Server 2012
Windows Server 2012
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
1,510 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,147 questions
0 comments No comments
{count} votes

Accepted answer
  1. Dave Patrick 426.1K Reputation points MVP
    2020-10-21T20:39:07.113+00:00

    May want to check for stale or incorrect records in DNS console. Also try ipconfig /registerdns on the problem DC and on problem member do ipconfig /flushdns or try to RDP the ip address instead of name. Also might try from PowerShell from source and target.

    Test-NetConnection -ComputerName "192.168.49.142" -CommonTCPPort "RDP" -InformationLevel "Detailed"

    --please don't forget to Accept as answer if the reply is helpful--

    0 comments No comments

4 additional answers

Sort by: Most helpful
  1. RawatP 61 Reputation points
    2020-10-21T21:00:52.277+00:00

    @Dave Patrick
    I have tried PowerShell and it is showing
    WARNING: TCP connect to (IP address : 3389) failed.

    But when I am trying to run below command it is working.
    Test-NetConnection -ComputerName "ComputerName" -Port "3389" -InformationLevel "Detailed"

    0 comments No comments

  2. Dave Patrick 426.1K Reputation points MVP
    2020-10-21T21:02:11.733+00:00

    I have tried PowerShell

    From source or target? Try the ip address? Need to try on both.


  3. Dave Patrick 426.1K Reputation points MVP
    2020-10-21T21:09:34.257+00:00

    Both Powershell run from source (my host machine)

    Need to do two things try using the ip address

    1. Test-NetConnection -ComputerName "192.168.49.142" -CommonTCPPort "RDP" -InformationLevel "Detailed"
    2. also try running on the target machine (old domain controller
    0 comments No comments

  4. RawatP 61 Reputation points
    2020-10-22T15:15:09.323+00:00

    Issue Resolve: It turnout Domain Profile Setting Firewall was on, After setting it off i was able to RDP of server

    @Dave Patrick Thanks a ton!!