Swapping CDs is not recognized when using Windows Media Player Legacy on a Remote Desktop Destination PC

kazami 0 Reputation points
2023-08-29T09:27:02.6933333+00:00

As a premise, I usually use a Surface Pro8, and when I want to use optical media, I connect to my desktop PC with Remote Desktop.

In Windows Vista and later, we need to enable All Removable Storage: Allow direct access in remote sessions in Group Policy in order to successfully use removable media at the Remote Desktop destination.

If we don't do this, we won't be able to do things like right-click eject.

Now, with that set up, when I launch Windows Media Player Legacy and insert the CD, it doesn't show up in the list.

If the disc was inserted before Media Player started, it will be displayed, but even if I replace the disc after starting, the display of the disc will not change.

If I operate from local interaction instead of Remote Desktop Connection, I can successfully recognize disc swapping.

The Explorer correctly recognizes the disc replacement.

Do I need any special settings in Media Player?

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,395 questions
Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,958 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Karlie Weng 16,351 Reputation points Microsoft Vendor
    2023-09-05T08:05:22.0733333+00:00

    Hello kazami

    Based on your description, we can explore some Remote Desktop Connection Settings and Media Player settings as follows:

    1.Try enabling the Use local resources on remote computer option in the options for Remote Desktop Connection.

    •  Click the Options button before connecting to the remote computer
    • Select the Local Resources tab.
    • Enable the Use local resources on remote computers option
    • Make sure the CD/DVD Drive checkbox under the Drive tab is selected.

     

    2.Check the Windows Media Player Legacy autoplay settings.

    • Open Windows Media Player Legacy ->Click the Tools menu, and then select Options.
    • In the Options dialog box, click the Playback tab.
    • In the AutoPlay section, select the AutoPlay when disc is inserted into the drive check box.
    • Select the type of content you want to play automatically in the drop-down menu, such as Audio CD or Video DVD.
    • Click the OK button to save the changes.

     

    If the previous steps do not yield the desired results, you may want to consider using an alternative media player.