Prevent files from being downloaded in SharePoint 2019

Thomas Stoker 0 Reputation points
2023-08-30T15:11:46.9533333+00:00

I'm trying to figure out how to stop standard users from downloading files from a sharepoint site, but instead have them always in a browser

I have tried to apply restricted permissions to a user group, but for some reason files are still being downloaded instead of opening in a separate browser window.

Is there anyone who would know anything I can try in order to get this to work?

Thanks in advance

SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
9,565 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Ling Zhou_MSFT 12,955 Reputation points Microsoft Vendor
    2023-08-31T07:46:06.8666667+00:00

    Hi @ Thomas Stoker ,

    Thank you for posting in this community.

    In SharePoint 2019, if you want to be able to open files in web pages, then you need to install Office Online Server. Office Online Server is an Office server product that provides browser-based file viewing and editing services for Office files.

    You can follow the articles below to install Office Online Server and configure it for SharePoint 2019:

    Please note that Office Online Server is not compatible with some services (e.g. SharePoint) and cannot be installed on the same computer.

    11

     

    1. Deploy Office Online Server - Office Online Server | Microsoft Learn.
    2. Configure Office Online Server for SharePoint Server 2016 - Office Online Server | Microsoft Learn(The article uses SharePoint 2016 as an example, but it also applies to SharePoint 2019).

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Ling Zhou_MSFT 12,955 Reputation points Microsoft Vendor
    2023-09-01T07:41:35.0633333+00:00

    Hi @Thomas Stoker,

    Thank you for your reply.

    If you want all PDF files to be opened in your browser, please do the following:

    1. Go to List Settings -> Advanced Settings ->Default open behavior for browser-enabled documents->select "Open in the browser".

    User's image

    2.Set the default behavior for PDF files for the browser you are using.

    In the Google Chrome browser, go to Settings -> Private and security -> Site settings ->Additional permissions-> PDF documents ->Open PDFs in Chrome.

    User's image

    In the Edge browser, go to Settings -> Cookies and site permissions -> PDF documents -> Disable Always download PDF files.

    User's image


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.