scom web console through azure app proxy

richard scott 106 Reputation points
2020-10-22T14:18:05.493+00:00

I have recently configured my scom 2019 UR2 web console to be externally accessible utilising the azure app proxy.
This seems to work to a degree whereby I can view some information (if directly linking) but when trying to navigate the left hand menu or health explorer nothing further loads
It appears only dashboards that have been created in the scom web console will display, all other links appear to do nothing.
Has anyone any experience of accessing a scom web console through the azure app proxy ?

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
18,551 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Marilee Turscak-MSFT 32,286 Reputation points Microsoft Employee
    2020-10-26T23:33:19.897+00:00

    Hi richardscott-8355,

    There is no existing guidance on this, but I believe it should be possible. A few things to check:

    1. Ensure that the user has the right role for accessing these views. Have you assigned at least the Operator role?
    2. Can you please check whether the User Role Properties includes the views that you are trying to access?
    3. Is there any error message that you see, or does it just not appear to load or seem to load slowly?
    4. Sometimes issues like this can occur if the user is removed from the Local Users Group. Please try adding the user to Local Users and Local Administrators group on the server hosting SCOM Web Console, and let me know if that makes any difference.

    See also:
    https://learn.microsoft.com/en-us/azure/active-directory/manage-apps/application-proxy-connectors


  2. Stefanos Papaefthimiou 0 Reputation points
    2023-12-06T06:42:26.47+00:00

    I found the solution, in Entra id\Enterprise application"your app"\application proxy\Basic settings, in the "Internal URL" field, instead of using "https://scomwebconsoleserver/OperationsManager" , I used "https://scomwebconsoleserver/". Works fine now.

    0 comments No comments