Always automatically restart at the scheduled time not taking effect on Windows 2019

Anonymous
2020-10-22T18:22:25.403+00:00

Server is Windows 2019

I have the following GPOs applied:

  • No auto-restart with logged on users for scheduled automatic updatest installationDisabled
  • Always automatically restart at the scheduled timeEnabled
  • Configure automatic updatesEnabled with auto download and schedule the install

However, on the actual server, when I go to Updates & Security > advanced options > view configured updates policies > it says:
Auto reboot will not happen with logged on users
source: Administrator
Type: Group Policy

I'm not sure why it's not getting the setting to always restart at the scheduled time.
I checked the RSOP data and the GPO is applied.

Any suggestions?

TIA

Windows
Windows
A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
4,499 questions
{count} votes

5 answers

Sort by: Most helpful
  1. udara peiris 671 Reputation points
    2020-10-23T01:00:00.94+00:00

    Check your policy settings again. It should be worked if you have scheduled to install updates at any specific time.

    And check your active hour settings and scheduled time again.

    Please refer following for further,
    https://learn.microsoft.com/en-us/windows/deployment/update/waas-restart

    (Don't forget to Accept as answer if this is helpful)


  2. Fan Fan 15,276 Reputation points Microsoft Vendor
    2020-10-26T07:47:35.693+00:00

    Hi,

    To make sure the GPO was applied, please also confirm the registry had been changed correctly:
    https://learn.microsoft.com/en-us/windows/deployment/update/waas-restart#registry-keys-used-to-manage-restart

    Best Regards,

    0 comments No comments

  3. Anonymous
    2020-10-27T20:16:00.98+00:00

    I checked the registry and it all looks correct. Any suggestions? ![35339-image.png][1] [1]: /api/attachments/35339-image.png?platform=QnA

    0 comments No comments

  4. Fan Fan 15,276 Reputation points Microsoft Vendor
    2020-10-28T01:30:37.897+00:00

    Hi,

    As you said , it seems the GPO applied successfully , and the registry also changed correctly.

    You can enable the GPSVC log to check more details ,if there are any errors:
    https://blogs.technet.microsoft.com/askds/2015/04/17/a-treatise-on-group-policy-troubleshootingnow-with-gpsvc-log-analysis/

    Best Regards,

    0 comments No comments

  5. MK 1 Reputation point
    2020-11-03T11:45:36.853+00:00

    Hi.
    We have same problem on each of W10 1909 or 2004 computer (about 500).
    GPO is applied successfully, because when i delete all registry setting in HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU , gpupdate adds the values back correctly.

    It's interesting that "Auto Reboot will not happen with logged on users" in Windows update advanced settings is displayed even if it is not set (neither GPO nor registry).
    And GPO/registry "No auto-restart with logged on users for scheduled automatic updates installations" / "NoAutoRebootWithLoggedOnUsers" have no effect on this function.

    No other GPO or local policy has windows update set, so there is no conflict.

    Edit: our screens
    GPO https://pasteboard.co/JyR18Am.png
    GPO CAU https://pasteboard.co/JyR1y15.png
    Computer registry wu https://pasteboard.co/JyR1TdT.png
    Computer registry wu-au https://pasteboard.co/JyR2kPK.png
    Computer policies view https://pasteboard.co/JyR2GkC.png
    Computer Windows update state https://pasteboard.co/JyR3mMb.png

    User is always logged in.

    Edit2: test
    I logged off the user yesterday afternoon, the computer was turned on all night.
    The user logged in this morning and WU immediately began to install pending updates.
    https://pasteboard.co/JyW4P2Q.png

    Then WU planned restart at noon.
    https://pasteboard.co/JyW6FcE.png

    So Windows Update ignores the settings in registry/GPO.

    0 comments No comments