Unable to set default home page for all users via local group policy settings for Edge

Jr W 1 Reputation point
2020-10-22T18:59:10.733+00:00

Hello,

I'm trying to set a default home page for the new chromium edge version 86.0.622.51 64-bit via local group policy on Windows 10 Pro Version 10.0.19041 Build 19041.

The instructions seem easy enough to follow and pretty intuitive. However, I just can't get the home page set no matter which user I login as, which way I format the url in the GP settings, or which computer I test it on. I should also mention that I'm currently in audit mode before sysprep, in preparation for capturing an image in case that has any implications.

I'll insert images below for the way I have it configured right now, but if someone could please tell me what I'm doing wrong it would be greatly appreciated.

34422-01a.jpg
34423-02b.jpg

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
1,340 questions
No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Deepak-MSFT 2,041 Reputation points Microsoft Employee
    2020-10-23T08:14:20.583+00:00

    @Jr W ,
    I try to check the policies that you had mentioned above in the original post.

    1. Configure Open Microsoft Edge With
    2. Configure Start Pages

    I noticed that the policies you had set are for the MS Edge legacy browser. This is the reason that you do not see any effect after setting these policies.

    If you want to set the group policies for the MS Edge Chromium browser then I suggest you refer to the steps below.

    1. You need to download the template policy files from this link.
    2. Install the policies by referring to this link.
    3. Start the Local Group Policy editor and you can see the policy template for Edge.

    34468-177.png

    Now, we can try to set the default page that gets open when you launch the Edge browser.

    We need to set the below 2 policies.

    1. Sites to open when the browser starts
    2. Action to take on startup

    Both policies are available under Computer configuration -> Administrative templates -> Microsoft Edge -> Startup, homepage and new tab page.

    34507-178.png

    You need to enable the Sites to open when the browser starts policy and set the desired URL of the site that you want to open while Edge gets launched.

    you need to enable the Action to take on startup policy and set its value to Open a list of URLs from the drop-down. Without setting this policy above policy will not work.

    Further, you can launch the Edge browser and see whether it opens the site that you had set using the group policy.

    ----------

    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.