Windows Sandbox & Hyper-V Degraded Network Issue

JEmlay 21 Reputation points
2023-09-04T19:05:25.8433333+00:00

Sandbox & Hyper-V have been working fine until the last time I tried to use it. I noticed it stopped loading webpages from Edge or would take minutes to load a single page. Same thing happens if I install FF or Chrome within Sandbox or on a VM. Attached image would be the reason why. However I can't figure out how to fix it. I've removed it, rebooted, re-installed it, rebooted. Nothing. Something is destroying it's ability to receive.

Windows 11
10Gb NIC
1Gb NIC disabled

I have Bluestacks installed and out of curiosity I ran speedtest on there as well. It's full speed.

At first I thought the root problem was the "Default Switch" that is created automatically. Unfortunately the internet isn't much help as everyone suggests to ditch that switch and create your own External Switch. Great for VMs but that's not an option for Sandbox. You can't even edit that Default Switch, it's locked in, everything greyed out.

Any help to diagnose this would be greatly appreciated!

Speed_Issue

EDIT:
More info. I disabled my 10Gb adapter then enabled my 1Gb adapter. Relaunched sandbox and full speed! What the heck? Why full speed on one adapter and not the other? Installed a new Win10 VM using Hyper-V and it as well was full speed. Went back to the 10Gb adapter and right back to 3Mbps download for both Sandbox and Hyper-V.

Uninstalled everything. Disabled the 1Gb adapter in BIOS. Reinstalled only Sandbox. Right back to 3Mbps download. Installed everything else. Loaded the VM and it was also right back to 3Mbps.

No driver update for the 10Gb adapter. Anyone else run into this issue?

EDIT2:
iperf3
Sandbox -> Host - 14.8Gbps

Host -> Sandbox - 3.2Gbps

I just get more and more confused. Why isn't it 14.8 both directions and if it can handle 3.2Gbps when why is the download from the internet so horrible?

Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,526 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Limitless Technology 43,916 Reputation points
    2023-09-06T09:00:23.15+00:00

    Hello there,

    The Windows Sandbox does require the underlying base of Hyper-V, whose feature is called "Virtual Machine Platform", but does not require the heavier upper part of Hyper-V, whose feature is called "Windows Hypervisor Platform".

    While running a non-Windows guest such as Linux on Hyper-V, the Hyper-V management console may display messages that indicate that the integration services for the non-Windows guest are degraded and no formal support will be provided unless the integration services are updated. This message is overtly aggressive in warning and users should feel free to ignore it. Microsoft will provide required support despite of these messages being shown in the Hyper-V console or the Windows event log.

    https://learn.microsoft.com/en-us/troubleshoot/windows-server/virtualization/degraded-integration-services-message

    Hope this resolves your Query !!

    --If the reply is helpful, please Upvote and Accept it as an answer--


  2. JEmlay 21 Reputation points
    2023-09-11T17:32:24.3766667+00:00

    Solved my own issue. Apparently Receive Segment Coalescing (RSC) was causing massive performance issues. This can be fixed in one of three ways by turning it off:

    Adapter Specific:
    Disable-NetAdapterRsc -Name "Ethernet" -IPv4 (can also do IPv6)

    or by individual virtual switch (doesn't apply to Sandbox since you can't alter the Default Virtual Switch):

    Set-VMSwitch -Name "vSwitchName" -EnableSoftwareRsc $false

    or system wide:

    netsh int tcp set global rsc=disabled

    Once again a feature automatically turned on by Microsoft caused a major problem. Most likely enabled at some point via an update.

    0 comments No comments