Unable to upload 50mb files to Azure App Service hosted application that uses Blazor

Bhoir, Harshal Mahendra 0 Reputation points

I am unable to upload 50mb files to azure app service hosted application, getting the error 413 Requested Entity Too Large. The application is able to upload the file while running locally to Azure Blob storage, but while it is running on Azure App service, it gives the 413 error. Tried editing the web.config on kudu console but cannot edit it since have used zip deploy option, is there any other solution. I also tried changing the WEBSITE_RUN_FROM_PACKAGE property to 0 in order to edit the web.config but doing so made many of the folders vanish from the kudu console so this too was not helpful.

Azure Blob Storage
Azure Blob Storage
An Azure service that stores unstructured data in the cloud as blobs.
1,962 questions
A free and open-source web framework that enables developers to create web apps using C# and HTML being developed by Microsoft.
1,110 questions
Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
5,663 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Michael Washington 876 Reputation points MVP

    Use: https://github.com/Tewr/BlazorFileReader

    Use the demo at: https://tewr.github.io/BlazorFileReader/ to try to upload a large file.