Windows 11 Edu - Large image Install - Updates Ran until Beginning of Sept 01/2023 then Stopped - Error Code 0x80072F8F with all windows services TLS 1.2 related?

matthew stavert 5 Reputation points

Hi There, We have a large install of Windows 11 Education for K-12. It is volume-licensed with KMS. We have used this image for over a year now and update the image often. Recently, I updated the image and prepped it for mass distribution, amounting to 191 new PCs. Updates were working After we imaged the PCs, and updates ran from the beginning of June 2023 until around Sept 15, 2023. All of a sudden, Windows Updates stopped working on ALL of the PCs, and when I ran Windows Update, I got the error code:


I the error code against err_6.4.5.exe and it returned the following:

Err_6.4.5.exe 0x80072F8F 

# for hex 0x80072f8f / decimal -2147012721 

  WININET_E_DECODING_FAILED                                      winerror.h 

# Content decoding has failed 

# 1 matches found for "0x80072F8F"

This "Seems" TLS-related, but when I look at my settings, TLS 1.2 and 1.3 are enabled on the OS Image. What brought this to my attention is that some users needed .NET 3.5 for some services and software, and I get the same error when trying to install .net 3.5.  As well, if I try to run Defender updates, I get the same error. Once again, ALL updates were working on all 191 PCs, and now ALL updates have stopped with this error message. I found an article from Microsoft saying Microsoft will stop support for earlier versions of TLS come September 1st, 2023. It *seems* as though this is affecting us, but I don't know how to fix it. And I am hoping to mass roll out a fix to 191 PCs instead of having to re-image them all.  I really think something happened on the Microsoft Update server end for some versions of Windows 11 Education, since its updates were working up to Sept 1, 2023.

Here is my Build Version:

Edition: Windows 11 Educaiton

Version 22H2

Installed on 2023-05-23

OS BUILD: 22621.1702

Experience: Windows  Feature Experiance Pack 1000.22641.1000.0

Any Hellp would be Much Apprecisted as I don't know why this is happening.

Windows Articles talking by End for previous TLS Support:
Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
6,018 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 42,296 Reputation points

    Hello there,

    Error code 0x80072f8f 20000 could show up because your PC can't properly communicate with Microsoft's servers. You can enable TLS 1.1 and TLS 1.2 by changing the system registry.

    Please try the methods below and check.

    1. Go to C:\Windows\SoftwareDistribution\Download and delete all files in that folder.
    2. Press Windows + X key on the keyboard.
    3. Go to Command Prompt as admin
    4. Type this command "wuauclt.exe /updatenow"
    5. Press Enter

    Similar discussion here

    Hope this resolves your Query !!

    --If the reply is helpful, please Upvote and Accept it as an answer–