Unable to Stop Insider Updates Windows 11 Pro

DH-5640 0 Reputation points
2023-09-11T21:48:15.63+00:00

I never signed up to be an insider. Have insider disabled. However, somehow I am on an insider build which is 22621.2191 and I keep being presented with more insider updates.

How can I get out of this insider nonsense and get back on a stable build? - I am set to share not to send additional diagnostic data, and all settings supposedly turning off insider builds are off, yet insider builds are being shoved at me. I have turned off all updates for 4 weeks. I cannot afford to be a beta-testing lab rat. Thanks.

Is there a group policy setting or registry setting to block insider updates that I can set? Since obvious settings do not work, perhaps nothing will work.

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
6,004 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Limitless Technology 41,906 Reputation points
    2023-09-12T14:36:04.9+00:00

    Hello,

    Thank you for your question and reaching out. I can understand you are having issues related to Windows insider updates

    Please check if you have done leaving insider

    Go to Settings > Update & Security > Windows Insider Program.

    Click on "Stop Insider Preview builds" and follow the prompts.

    Click on the "Stop Insider Preview builds" button.

    Restart the pc and check

    If still having the same issue

    Please reset the windows.

    and see it helps.

    Thank you

    --If the reply is helpful, please Upvote and Accept as answer--

    0 comments No comments

  2. Kapil Arya 6,651 Reputation points MVP
    2023-09-13T06:46:18.91+00:00

    Hello,

    See if this fix helps you:

    https://www.kapilarya.com/stop-receiving-insider-builds-in-windows-11-and-switch-to-stable-version

    Let us know if this helps!

    Note: Included link in this reply refers to blog post by a trusted Microsoft MVP.

    0 comments No comments

  3. DH-5640 0 Reputation points
    2023-09-15T14:19:05.8633333+00:00

    I think I solved this by modifying gpedit settings as in this link

    https://superuser.com/questions/1623310/disallow-preview-windows-10-updates

    0 comments No comments