Microsoft.Azure.Functions.ExtensionBundle error remains after updating host.json and settings.json

Mingkai Liu 50 Reputation points
2023-09-14T07:38:13.7833333+00:00

I got a warning regarding the EOL of runtime 2.x and python 3.8 of the azure functions currently running. So I changed of the runtime setting to ~4 and python version to >=3.9 in the Settings/Configuration of the function app.

After restart the function app, I got an error of minimal version requirement of the Azure.Functions.ExtensionBundle, and requires me to change the host.json.

Error code

AZFD0005

Level

Error

Message

Error building configuration in an external startup class.

Details

Microsoft.Azure.WebJobs.Script.ExternalStartupException : Error building configuration in an external startup class. ---> Microsoft.Azure.WebJobs.Script.HostInitializationException : Referenced bundle Microsoft.Azure.Functions.ExtensionBundle of version 1.8.1 does not meet the required minimum version of 2.6.1. Update your extension bundle reference in host.json to reference 2.6.1 or later. ....

Then I clone the source code of the function app to local and change the host.json, in which I change the "version" of the "extension bundle" to [3.3.0, 4.0.0).

I also change the projectruntime to ~4 in the 'settings.json' (both of them)

User's image

Then save, commit, sync and deploy the changes to the function app.

After deployment and restart of the function app, I can see the changes from the portal

User's image

But I still get the same error as if the version of the extensionbundle has not been changed.

User's image

  • So I am not sure which part I did wrong, any help will be really appreciated.

Thanks!

Azure Functions
Azure Functions
An Azure service that provides an event-driven serverless compute platform.
4,249 questions
0 comments No comments
{count} votes

Accepted answer
  1. MuthuKumaranMurugaachari-MSFT 22,141 Reputation points
    2023-09-14T14:57:33.72+00:00

    Mingkai Liu Thanks for posting your question in Microsoft Q&A. Based on the description, you are looking to upgrade function runtime to v4. As per Extension Bundles doc, you need to refer version as [4.0.0, 5.0.0).

    User's image

    Not sure why the error message didn't specify the right version. Please update the version and let me know if you still face the issue.

    Migrate apps from Azure Functions version 3.x to version 4.x might also help with testing locally and run pre-upgrade validator.

    2 people found this answer helpful.

0 additional answers

Sort by: Most helpful