SA user password

RIDEE COMPUTER 0 Reputation points
2023-09-28T22:47:13.3933333+00:00

Hello Professionals

I just setup my first sql server database on azure online but cannot use "sa" as a database user, but my application connection default (fixed) user is "sa" only.

Please how can i get the password for "SA" or create the "sa" account for my database

thank you

Azure SQL Database
SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
12,850 questions
{count} votes

3 answers

Sort by: Most helpful
  1. CosmogHong-MSFT 23,556 Reputation points Microsoft Vendor
    2023-09-29T07:26:25.04+00:00

    Hi @RIDEE COMPUTER

    How about create a SQL authentication login, add a user mapped to it in master and add the user to a server level admin role.

    Refer to this article for more details: Adding Users to Azure SQL Databases.

    Best regards,

    Cosmog Hong


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our Documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. Erland Sommarskog 102.2K Reputation points
    2023-09-29T14:43:02.5166667+00:00

    As far as I know there is no sa in Azure SQL Database, and in any case using sa as an application login is very bad practice. An application login should ideally only have permission to run stored procedures, and never more than SELECT/INSERT/UPDATE/DELETE permissions.

    0 comments No comments

  3. Rahul Randive 8,826 Reputation points Microsoft Employee
    2023-09-29T15:00:14.1966667+00:00

    Hi @RIDEE COMPUTER

    For Azure SQL Server, you can retrieve the Server Admin from the portal, and if you are not aware of the password, you can reset it if you are the owner

    Snippet below-

    User's image

    Thank you!

    0 comments No comments