How to create a cluster with the CLI

Kevin Maier 20 Reputation points
2023-10-02T12:19:10.8666667+00:00

Hello,
I would like to create a Azure Data Explorer cluster with the Azure CLI on Ubuntu20.04. I currently have version 2.0.81 installed. I tried to follow the instructions from here: https://learn.microsoft.com/en-us/cli/azure/kusto?view=azure-cli-latest, but the command az extension add -n kusto just returns an error: No matching extensions for 'kusto'. Use --debug for more information.
When I run the command az kusto cluster create -l "Central US" -n myclustername -g myrgname --sku D13_v2 --capacity 2 I get the error:

The command failed with an unexpected error. Here is the traceback:

__init__() missing 1 required keyword-only argument: 'tier'
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/knack/cli.py", line 206, in invoke
    cmd_result = self.invocation.execute(args)
  File "/usr/lib/python3/dist-packages/azure/cli/core/commands/__init__.py", line 608, in execute
    raise ex
  File "/usr/lib/python3/dist-packages/azure/cli/core/commands/__init__.py", line 666, in _run_jobs_serially
    results.append(self._run_job(expanded_arg, cmd_copy))
  File "/usr/lib/python3/dist-packages/azure/cli/core/commands/__init__.py", line 659, in _run_job
    six.reraise(*sys.exc_info())
  File "/home/kevin/.local/lib/python3.8/site-packages/six.py", line 719, in reraise
    raise value
  File "/usr/lib/python3/dist-packages/azure/cli/core/commands/__init__.py", line 636, in _run_job
    result = cmd_copy(params)
  File "/usr/lib/python3/dist-packages/azure/cli/core/commands/__init__.py", line 306, in __call__
    return self.handler(*args, **kwargs)
  File "/usr/lib/python3/dist-packages/azure/cli/core/__init__.py", line 493, in default_command_handler
    return op(**command_args)
  File "/usr/lib/python3/dist-packages/azure/cli/command_modules/kusto/custom.py", line 44, in cluster_create
    _cluster = Cluster(location=location, sku=AzureSku(name=sku, capacity=capacity))
TypeError: __init__() missing 1 required keyword-only argument: 'tier'
Command
    az kusto cluster create : Create a Kusto cluster.

Arguments
    --name -n           [Required] : The name of the cluster.
    --resource-group -g [Required] : Name of resource group. You can configure the default group
                                     using `az configure --defaults group=<name>`.
    --sku               [Required] : The name of the sku.  Allowed values: D11_v2, D12_v2, D13_v2,
                                     D14_v2, L16, L4, L8.
    --capacity                     : The instance number of the VM.
    --location -l                  : Location. Values from: `az account list-locations`. You can
                                     configure the default location using `az configure --defaults
                                     location=<location>`.
    --no-wait                      : Do not wait for the long-running operation to finish.

Global Arguments
    --debug                        : Increase logging verbosity to show all debug logs.
    --help -h                      : Show this help message and exit.
    --output -o                    : Output format.  Allowed values: json, jsonc, none, table, tsv,
                                     yaml.  Default: json.
    --query                        : JMESPath query string. See http://jmespath.org/ for more
                                     information and examples.
    --subscription                 : Name or ID of subscription. You can configure the default
                                     subscription using `az account set -s NAME_OR_ID`.
    --verbose                      : Increase logging verbosity. Use --debug for full debug logs.

Examples
    Create a Kusto Cluster.
        az kusto cluster create -l "Central US" -n myclustername -g myrgname --sku D13_v2 --capacity 10

tier does not seem to be a suported argument.
Is there any documentation for a currently supported version of the CLI that shows how to deploy a cluster?

Azure Data Explorer
Azure Data Explorer
An Azure data analytics service for real-time analysis on large volumes of data streaming from sources including applications, websites, and internet of things devices.
489 questions
0 comments No comments
{count} votes

Accepted answer
  1. Sander van de Velde 29,691 Reputation points MVP
    2023-10-02T12:30:39.4433333+00:00

    Hello @Kevin Maier,

    it seems you are using an older version of the AZ CLI for Ubuntu.

    The current version of the Azure CLI is 2.53.0. For information about the latest release, see the release notes.

    Can you update the CLI and try again?


    If the response helped, do "Accept Answer". If it doesn't work, please let us know the progress. All community members with similar issues will benefit by doing so. Your contribution is highly appreciated.

    1 person found this answer helpful.

0 additional answers

Sort by: Most helpful