Standalone computers can not download updates from WSUS: unable to find resource reportingevent.client.167

Mohamed SAKHO 116 Reputation points
2023-10-02T14:25:36.8966667+00:00

Hello, I made a modification to my WSUS environment to change the server URL from http to https.

by following the following procedure.

https://www.it-connect.fr/chapitres/wsus-https-avec-un-certificat-ssl-pour-plus-de-securite/

Since then I have encountered a problem when downloading updates for my non-domain machines for which it worked because I specified for these machines the IP of my server in the registry followed the 8530 port.

User's image

And so since I switched to https by specifying the WSUS address followed the 8531 port, and since my machines (non-domains) are no longer able to download their updates.

I used the method using my company's certificate authority, installed on my client machines Iinstalled the correct certificates in the trusted root authority and personal store (wsus) stores.

I also noticed that since my change, I have a lot of errors linked to IIS services like the image in attached file.

User's image

And in the WSUS console by selecting one of my client machines (outside the domain) in error, I get the message below.

User's image

Did I miss a step in my actions?

Thanks for your help.

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,252 questions
0 comments No comments
{count} votes

4 additional answers

Sort by: Most helpful
  1. Adam J. Marshall 8,886 Reputation points MVP
    2023-10-04T15:37:46.3566667+00:00

    Non-domained - sounds like you missed the 1 step to import the SSL Certificate as a trusted certificate on the client!

    https://www.ajtek.ca/wsus/how-to-setup-manage-and-maintain-wsus-part-7-ssl-setup-for-wsus-and-why-you-should-care/

    0 comments No comments

  2. Mohamed SAKHO 116 Reputation points
    2023-10-05T14:38:29.2666667+00:00

    Hello @adam J. Marshall,

    Thank you for your response.

    on the non-domained computers, I already import my internal CA in Trusted Root Certification authorities>certificate and import my wsus ssl certiificate in personal>certificate but it doesn't work. But I mean normally the certification authority should be enough..no ?


  3. Mohamed SAKHO 116 Reputation points
    2023-10-09T14:38:25.99+00:00

    Hello Adam,

    when I try to download the cab file as it shows in the article, it's works fine, when I brose to the url as it shows in the same article, it works fine also.

    0 comments No comments

  4. Mohamed SAKHO 116 Reputation points
    2023-10-11T11:49:23.2033333+00:00

    Hello it looks good when I ran the client side script. The non-domain devices retrieve their updates.

    Thank you Adam.

    0 comments No comments