Azure Machine Learning Missing Dataset Input Version

Fuselli Daniele 0 Reputation points
2023-10-03T09:43:41.4866667+00:00

Hi,

I'm using python SDK to perform the following workflow:

  • create a new dataset named "classification_observation_input" (automatically dataset version is increased)
  • invoke pipeline endpoint attaching the dataset create in previous point (so with that specific version)

always worked fine for months but few days ago I had an issue where a pipeline was executed on a dataset of the wrong version.

  • created new dataset (version 146)
  • invoke pipeline with dataset 146
  • Azure Machine Learning execute pipeline with dataset version 145 (the 145 version was created 9 days before!)

Other considerations:

  • The very strange thing is that dataset version 146 is not present into available versions of that dataset (attached screenshot). We never delete a dataset version in any way
  • We tried a test without passing any dataset when invoking pipeline and we see that pipeline is executed with version 1 ( the default value set when we created the pipeline endpoint).

what could have happened?

Azure Machine Learning
Azure Machine Learning
An Azure machine learning service for building and deploying models.
2,611 questions
{count} votes