SharePoint site page images are not visible for the visitors

Diana Bekibaeva 10 Reputation points
2023-10-04T10:44:37.7733333+00:00

Hello,

I'm experiencing an issue with a SharePoint site page. When I share the site with others to let them view, everything is visible to them except for the images on the main page. But for me as an owner, everything appears fine. There are no error messages; it's just displaying empty space for the images.

Is there a solution or explanation for this problem?

Thanks!

SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
9,870 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Haoyan Xue_MSFT 20,906 Reputation points Microsoft Vendor
    2023-10-05T02:34:15.53+00:00

    Hi @Diana Bekibaeva ,

    I’m sorry to hear that you are having trouble with your SharePoint site page images. There are a few possible reasons and solutions for this problem.

    1.One reason could be that the images are not published or approved, and only visible to you as the owner. You can check the status of the images by going to the library where you uploaded them, and see if they have a green circle with a check mark next to them. If not, you need to publish or approve them so that they can be seen by others.

    2.Another reason could be that the permissions for the images or the library are not set correctly. You need to make sure that the visitors have at least Read permissions on the images and the library where you uploaded them. The image is probably located in a folder that visitors do not have routine access to. If you want it to be visible to all users then the best place to put it is in a sub fodler in the site assets library. You can check the permissions by going to the library settings, and then clicking on Permissions for this document libraryYou can also check the site level permissions or the individual page level permissions by following the steps in this link.

    3.A third reason could be that the field controls for the images are set to show only in edit mode and not in view mode. This means that the images will only appear when you are editing the page, but not when you are viewing it. You can check the field controls by going to the page layout settings, and then looking for the edit mode settings for the Page Image field control. You need to make sure that it is set to show in view mode as well.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.