RSOP Precedence error message

Jay 256 Reputation points
2023-10-04T15:17:38.4566667+00:00

Seeing an error when checking RSOP to see if group policy is applying correctly that says "There was not enough memory available to load the database" when looking at the precedence tab for a GP setting. Basically have folder permissions and audit settings set in Computer Configuration>Policies>Windows Settings>Security>File System. Have several folders listed. Some say the policy applied successfully, and some have Red X circles next to them giving the memory error above. The folders that have the error are folders for McAfee EPO. I thought maybe there could be some setting in McAfee preventing GPO from applying to these folders? Anyone else seen this error before?

Windows
Windows
A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
4,829 questions
0 comments No comments
{count} vote

1 answer

Sort by: Most helpful
  1. Wesley Li-MSFT 4,381 Reputation points Microsoft Vendor
    2023-11-03T07:08:29.77+00:00

    Hello

    The error message “There was not enough memory available to load the database” when checking RSOP (Resultant Set of Policy) can be due to various reasons. Here are a few potential solutions:

    Clear Group Policy History: You can try removing all GPO history from the user’s profile by deleting this registry key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy\History. Then do a gpupdate and log off and on to see if that resolves the issue.

    Check McAfee Settings: If the folders with the error are for McAfee EPO, there could be some settings in McAfee that are preventing the GPO from applying to these folders. You might want to check the McAfee settings or reach out to McAfee support for further assistance.

    Check Folder Permissions: Ensure that the system has the necessary permissions to access and modify the folders in question.

    0 comments No comments