Resource was disallowed by policy. Reasons: 'Must enter a description for resource groups'. See error details for policy resource IDs.

FW 0 Reputation points
2023-10-04T19:10:59.66+00:00

Hi, Azure noob here. Sorry for generic tag, I couldn't find anything better.

I want to create a node app. First I went to "Create Web App + Database" filled in everything I could, pressed review + create. Then I got the error in the title.

I just created my own free account so to my knowledge there is no subscription manager. In the policy panel, I see 100% overall resource compliance.

I also tried to first creating a resource group. Here I could actually press review + create and everything got validated just fine, but when I actually pressed Create, I got the same error, but also no field to actually enter any sort of description.

What can I do? Any help would be appreciated.

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
7,052 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. brtrach-MSFT 15,356 Reputation points Microsoft Employee
    2023-10-06T23:41:47.6533333+00:00

    @FW That's an odd error as I do not think I've ever seen a text box to enter a description for a resource group in the 9+ years I have been using Azure.

    Could you please try the preview portal to see if you receive the same validation error?

    https://preview.portal.azure.com

    If you still receive the same error, please reply here and we can proceed with steps to take next.


  2. TP 79,156 Reputation points
    2023-10-11T01:37:05.87+00:00

    Hi,

    Based on the error there is an Policy assignment that is blocking the resource group creation. Please attempt to create a web app, then once it errors out, examine the error message until you find policyAssignmentDisplayName and make a note of the value next to it in quotes. In sample screenshot below, the value for policyAssignmentDisplayName is "Require a tag on resource groups":

    azure policy webapp error

    Once you have the policyAssignmentDisplayName, please navigate to Azure Policy assignments blade:

    https://portal.azure.com/#view/Microsoft_Azure_Policy/PolicyMenuBlade/~/Assignments

    Examine the list to see if you can find an assignment that matches, similar to sample screenshot below:azure policy webapp assignment

    If you find it, you can click its context menu (three dots on right) and edit or delete it.

    Please click Accept Answer if the above was useful.

    Thanks.

    -TP

    0 comments No comments