The sentence translated to English is: Fix SQL Server or SSMS startup error on Windows 11 Pro

Darlan Sandro 20 Reputation points

The sentence translated to English is: After installing the DBMS and SSMS, every time I run SSMS and try to create a query, it points to the following error:

Follow the video:

The sentence translated to English is: TITLE: Microsoft SQL Server Management Studio------------------------------

Unable to apply connection settings. Detailed error message: Incorrect syntax near the keyword ‘SET’.


The sentence translated to English is: The error occurs at the startup of SSMS. In an attempt to resolve it, I have already uninstalled SQL Server and SSMS, reinstalled them, and had no success. However, even with the error, I can execute the codes during the classes, but I have not found any solution so far.

Thank you for the help!

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
12,878 questions
0 comments No comments
{count} votes

Accepted answer
  1. Erland Sommarskog 102.3K Reputation points

    The error appears to be benign. That is, while you get an error, you should be able to use the query window.

    When you open a new query window, SSMS will submit a number of SET commands, as configured on these tabs:

    User's image

    User's image

    I don't see why any combination would yield syntax error, and if they do that would be a bug. But you may want to check your settings.

1 additional answer

Sort by: Most helpful
  1. 2023-11-25T12:42:59.6+00:00

    This bug is also reproduced in the Russian version. The SSMS configuration stores the localized value of the parameter. This can be temporarily corrected by editing the configuration file %APDATA%\Microsoft\SQL Server Management Studio\19.0\UserSettings.xml (parameter name "SetTransactionIsolationLevel"). But it will break every time you open the SSMS options window, so it’s better to make a backup of the corrected file.

    0 comments No comments