Search not functioning after changing DCOM settings

Siang Kiat Neo 5 Reputation points
2023-10-10T06:03:10.5166667+00:00

After changing the computer-wide DCOM default Authentication Level in Component Services from 'Connect' to 'None' and restarting the machine, the Search function no longer works. Typing in the search bar, pressing Win+S or typing anything with the start menu open does not give any response.

This is repeatable for multiple machines running Win10 Enterprise and Home, 22H2.

I'm unsure if this is related, but I found some Application Errors in Event Viewer:

Faulting application name: SearchApp.exe, version: 10.0.19041.3393, time stamp: 0x81c6e58e
Faulting module name: KERNELBASE.dll, version: 10.0.19041.3393, time stamp: 0x6b4de7c9
Exception code: 0xc0000409
Fault offset: 0x000000000012d9b2
Faulting process id: 0x4d0
Faulting application start time: 0x01d9f686b2517b56
Faulting application path: C:\Windows\SystemApps\Microsoft.Windows.Search_cw5n1h2txyewy\SearchApp.exe
Faulting module path: C:\Windows\System32\KERNELBASE.dll
Report Id: 030cdbec-0d0f-4cd7-bf7c-14b9001f0264
Faulting package full name: 
Faulting package-relative application ID: 

There was also an almost identical event with Exception code 0xc000027b.

I have already tried ending the SearchApp task from task manager and starting the .exe manually, but nothing changed.

Reverting the authentication level back to 'Connect' will fix the issue, but I'm not allowed to do this due to legacy applications that are dependent on this.

Does anyone have any kind of alternative?

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,762 questions
Windows 10 Compatibility
Windows 10 Compatibility
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Compatibility: The extent to which hardware or software adheres to an accepted standard.
459 questions
{count} vote