Changes of Exchange Online Public Folders (Add/Delete/Move) is only executed overnight after successful migration from OnPrem.

Rudel, Rüdiger 0 Reputation points

Hi Everybody,

after a successfull migration of OnPremise Exchange 2016 PublicFolders to ExchangeOnline I´ve a strange effect.

When a user with "owner" privileges tries to add a new PublicFolder (in EXO) he get´s an error message in his Outlook 365:
"Ein Clientvorgang ist Fehlgeschlagen" (Sorry, I don´t know the english error message)

Nevertheless, the next day this Folder is visible for the user. (Same effect, when moving an existing folder to a different folder).

The Exchange-Admin can see this folder at that moment when it is created (Standard behaviour) and he can also do all the standard tasks (Add/Delete/Move) just in time.

All User Mailboxes had been migrated successfully to EXO before the Migration of the OnPrem-PublicFolders. The PF-Migration had been completely finalized as described in:

Anybody an idea?

Thank´s in advance!


Microsoft Exchange Online
{count} votes

2 answers

Sort by: Most helpful
  1. Amit Singh 4,851 Reputation points

    This issue typically occurs because the public folder hierarchy replication isn't completed or has problems.

    Check this MS article -

    0 comments No comments

  2. Jarvis Sun-MSFT 10,091 Reputation points Microsoft Vendor

    Hi @Rudel, Rüdiger,

    Welcome to our Q&A forum!

    It seems that the user with “owner” privileges is receiving an error message in Outlook 365 when trying to add a new PublicFolder (in EXO): “A client operation failed”. However, the next day this folder is visible for the user. The same effect occurs when moving an existing folder to a different folder. This issue usually occurs when the replication of the public folder hierarchy is incomplete or faulty.

    To resolve this issue, you can manually replicate the permissions on the user’s public folder mailbox by running the following command:

    Update-PublicFolderMailbox pubmbx1 -InvokeSynchronizer

    Then, verify the permissions again by running the following command:

    Get-PublicFolderClientPermission \\puf1 -User User1 -Mailbox pubmbx1

    Please note that it may take a few minutes for the permission change to be displayed. For more information on troubleshooting public folder issues, please refer to this Microsoft article:

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment". 

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments