Unable to delete a Storage Account (classic)

Marco Rozo 20 Reputation points
2023-10-16T15:49:09.32+00:00

I have deleted everything from my Azure subscription, however when I try to delete a Storage Account (classic) the error message says:

Failed to delete storage account 'xxx'. Error: Unable to delete storage account 'xxx': 'Storage account xxx has some active image(s) and/or disk(s), e.g. yyy. Ensure these image(s) and/or disk(s) are removed before deleting this storage account.'.

And as I said the subscription is empty, the only thing left is this storage account, all VMs, all Disks, everything is gone.

Azure Storage Accounts
Azure Storage Accounts
Globally unique resources that provide access to data management services and serve as the parent namespace for the services.
2,746 questions
0 comments No comments
{count} votes

Accepted answer
  1. KarishmaTiwari-MSFT 18,627 Reputation points Microsoft Employee
    2023-10-16T19:48:20.7266667+00:00

    @Marco Rozo Thanks for posting your query on Microsoft Q&A.

    In addition to the suggestions shared by Shiva above, you can also try to


    I hope this helps! Let me know in the comments if you have further questions. Comment is the fastest way to reach the experts for any questions or help you need.

    Please don’t forget to Accept Answer and hit Yes for "was this answer helpful" wherever the information provided helps you, this can be beneficial to other community members for remediation for similar issues.

    1 person found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. shiva patpi 13,146 Reputation points Microsoft Employee
    2023-10-16T19:32:42.7466667+00:00

    @Marco Rozo ,

    There might be some disks in that particular storage account. Can you kindly check the containers, blobs for any VHDs in that particular storage account & delete those VHDs/Disks first?

    Previously if you have created a classic VMs , those classic VMs used to store the corresponding VHDs (disks) in a storage account. That might be the scenario which you might be facing now...i.e., you might have deleted all the classic VMs without deleting the underlying VHDs and those VHDs are stale but still stored in the storage account!!!

    Let us know if that helps ! or else you might have to file a request with the support to troubleshoot further so that they can help you out!

    Regards,

    Shiva.