Synapse Auto Integration Runtime Disappeared

Keith Pendergast 0 Reputation points
2023-10-16T19:05:42.4833333+00:00

Our production Synapse Auto Integration Runtime has disappeared. When I loaded the workspace today I was greeted with below:

User's image

I am relatively new to Synapse, but no changes or releases were made - so what are my options for resolution and troubleshooting?

None of my pipelines load (as they reference something which does not exist) -however I did manually re-run an hourly job, and it surprisingly worked, even though everything we have points to the AutoResolveIntegration runtime.

Azure Synapse Analytics
Azure Synapse Analytics
An Azure analytics service that brings together data integration, enterprise data warehousing, and big data analytics. Previously known as Azure SQL Data Warehouse.
4,444 questions
{count} votes

1 answer

Sort by: Most helpful
  1. PRADEEPCHEEKATLA-MSFT 78,986 Reputation points Microsoft Employee
    2023-10-17T10:04:58.95+00:00

    @Keith Pendergast - Thanks for the question and using MS Q&A platform.

    Could you please confirm the permission on the Synapse workspace which you are trying to login?

    According to the offical documentation: Azure Synapse access control

    To create these resources, you need to be an Azure Owner or Contributor on the resource group. To manage them once created, you need to be an Azure Owner or Contributor on either the resource group or the individual resources.

    User's image

    According to the offical documentation: Synapse RBAC Roles
    Note: Synapse RBAC roles do not grant permissions to create or manage SQL pools, Apache Spark pools, and Integration runtimes in Azure Synapse workspaces. Azure Owner or Azure Contributor roles on the resource group are required for these actions.

    And permission on the Synapse Portal: Access control:User's image

    Make sure you have required permissions to access workspace:

    • From Azure Portal under Synapse Workspace, user needs to have Owner/Contributor permission
    • From Azure Portal under Synapse Workspace, user needs to enable correct IP address under firewall settings

    Option1: Try to manually login by going to the https://web.azuresynapse.net and sign into your workspace.

    enter image description here

    For more information, refer to the Open Synapse Studio

    Option2: You please try the below:

    1. Clear “Cookies and Cached data” of your browser.
    2. Private Mode (New InPrivate Window).
    3. Try in different browser.

    In case, none of the steps worked for you - kindly share the screenshot of the permission you had on the Azure Synapse Workspace from Azure Portal and Azure Synapse Portal.

    Hope this helps. Do let us know if you any further queries.


    If this answers your query, do click Accept Answer and Yes for was this answer helpful. And, if you have any further query do let us know.