Time Series ID Property is getting null in TSI Explorer

Vikas Singh 145 Reputation points
2023-10-17T10:16:02.16+00:00

I am getting the data from PLC to IoT Hub and now trying to integrate IoT Hub with Time Series Insights.

I have selected my IoT Hub under Even Sources and then selected iothubowner policy and consumer group selected default.

However, when trying to see the telemetry data of tags in TSI Explorer then it is showing null value of Time Series ID Property. Please help how to fix the null value issue.

Azure Time Series Insights
Azure Time Series Insights
An Azure internet of things (IoT) analytics platform to monitor, analyze, and visualize industrial IoT analytics data at scale.
76 questions
0 comments No comments
{count} votes

Accepted answer
  1. Sander van de Velde 29,616 Reputation points MVP
    2023-10-17T10:26:32+00:00

    Hello @Vikas Singh ,

    be aware Time Series Insights will be retired, March 2025.

    I recommend using Azure Data Explorer as a TimeSeries database.

    ADX offers far more options to ingest, query, and visualize the data.

    Check out this blog post about getting started for (almost) free.

    The only thing I missed when switching to ADX was that visual 'slice and dice' user interface.

    Microsoft offers this Kusto Trender SDK but in the end we got much more value out of our data using the KQL query language and dashboard integration with eg. Grafana.

    Regarding your question, check if you use a separate consumer group while connecting to the IoT Hub. Also, it can take some time until the data starts to flow in. Refreshing your TSI dashboard can help also.


    If the response helped, do "Accept Answer". If it doesn't work, please let us know the progress. All community members with similar issues will benefit by doing so. Your contribution is highly appreciated.


0 additional answers

Sort by: Most helpful