Office 365's Your privacy matters dialog kept popping up.

Woody Chiu at RASI 191 Reputation points

Every time any of the Microsoft 365 applications opens, this dialog pops.

User's image

Any idea why it happens and how to get rid of it?


Microsoft 365
Microsoft 365
Formerly Office 365, is a line of subscription services offered by Microsoft which adds to and includes the Microsoft Office product line.
3,925 questions
Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
19,855 questions
{count} vote

1 answer

Sort by: Most helpful
  1. Navya 4,395 Reputation points Microsoft Vendor

    Hi@Woody Chiu at RASI , thanks for reaching us.

    I understand you are experiencing an issue where the "Your privacy matters" dialog keeps popping up every time any of the Microsoft 365 applications opens.

    The "Your privacy matters" dialog is a consent prompt that appears when an application requests permission to access a protected resource in Microsoft 365.You can choose whether to use these experiences or not, but the dialog box will keep appearing until you make a decision.

    To disable the "Your privacy matters" dialog in Office 365 applications, you can follow these steps:

    1.Open any Office 365 application, such as Word or Excel.

    2.Click on File, then select the Options.

    3.From the Options window, Click Trust Center -> Trust Center Settings

    4.Click Privacy Options -> Privacy Settings

    5.Uncheck the "Turn on optional connected experiences" box -> click ok.

    6.Restart the office applications.

    After completing above steps, the "Your privacy matters" dialog should no longer appear when you open Office 365 applications.

    Hope this helps. Do let us know if you any further queries.



    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.

    2 people found this answer helpful.